Skip Navigation

[Closed] New settings popup appears BELOW already open popup and can't edit content cell

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Beda 6 years, 3 months ago.

Assigned support staff: Beda.

Author
Posts
#328790

I am trying to edit a content template cell in Layouts. For this a popup appears specifically for editing content template cell. When I click on the Fields and Views button, the new popup that is supposed to help me set up the parameters appears BEHIND this content template cell editor popup, and only becomes visible if I close the content template cell editor popup first. But after that there is no more chance to insert the shortcode based on my settings.
Anyone has this issue or knows how to solve it?

#328797

Thank you for contacting us here in the Support Forum and for providing the Debug Informations

I have observed that issue in past, but its not present in my current fresh, updated WordPress install.

Your Plugins seem all up to date, nonetheless I would like to ask you two details:

1. Did the issue appear suddenly after a certain Update?

2. Does the issue also persist with a WordPress Default Theme and NO Plugins BUT the Toolset Plugins?

If not, could you then re-enable the Plugins one after the other, and check the issue each time you enable a plugin?
Please report me when the issue comes back

It might also be due to the Theme.
Please do reactivate your Theme only after you are sure the issue isn't coming form a 3rd Party Plugin.

3. If both above are negative results, please:

❌ Backup your website and database ❌
• Deactivate/Delete the "Installer" plugin (if you have it)
• Deactivate all Toolset plugins
• Login via FTP to your wp-content/plugins folder
• Delete all Toolset Plugins folders
• Go to https://toolset.com/account/downloads/ and download the latest stable Types Plugin, then extract it.
• Upload the plugin via FTP to the wp-content/plugins folder.
⌥ alternatively you could upload the .zip file using Dashboard > Plugins > New > Upload
• Register the Plugin for your site
⌥ you can do that under Dashboard > Types > Settings > Types Tools > Installer
• Download all other needed Plugins
• Activate them in Dashboard > Plugins
This should not generate any problems.

⌥ In case you want to register Toolset Plugins for your site manually please make sure to enter the naked URL of your site in wp-types.com (something like hidden link)

⌥ In the extreme case, please try to register with all non-Toolset Plugins deactivated,
and Theme Toolset Bootstrap enabled.

Please don't hesitate to inform me in case the issue persists and let me know if the above solution works for you, I look forward to your reply!

Thank you for your patience.

#328804

Before I delete and reinstall everything - it's no problem because my site is empty and I currently only use it for playing with Toolset -, can you help me with one thing?
I would like to create my own themes, the kinds that fits my clients' requirements. So far I used fancy themes but they didn't really live up to the expectations in terms of functionality.
Can you give me a useful tip how to install a theme or what to do in order to be able to create a unique theme after I put everything back?
Thanks.

#328809

Thanks for the Details

First of all, you don't loose any content doing above steps, as long you don't edit the Database and follow the steps

FTP Files don't hold any settings or contents so far.

Building themes is a great and interesting task, I personally love it.

I can suggest 2 things to start with:

1. Use one of our starter themes from here:
https://toolset.com/account/downloads/#toolset-themes

Those are minimalist, customizable theme blueprints already integrated with toolset.

You can follow this DOC on how to deliver Themes built with Toolset directly to your Customers:
https://toolset.com/documentation/embedded-toolset/
https://toolset.com/documentation/embedded-toolset/building-and-distributing-toolset-based-themes/

2. If you want to start from the 0 point scratch, I can personally recommend hidden link
(unfortunately a paid service, but not related to Toolset at all)

This guy has a amazing Step by Step Tutorial that teaches you to build WordPress Bootstrap theme from the absolute scratch, you gonna learn HTML, CSS and PHP along this too.
I can only recommend it.

There are also free Tutorials, like these:
hidden link
hidden link
hidden link

Please let me know if you have further questions regarding the issue mentioned in this Thread

Thank you for your patience.

#328823
Layouts install error.jpg

Thanks for your help, these are really awesome links and info!

As for the plugin reinstallation, I decided to just install it on another of my domains and see whether it's the same there - it's quicker and easier, and I would need it there anyway.
And I noticed something.
Is it possible that there is an issue with how Layout gets installed through the plugins page list where I just check it in and download/activate it? Because it got stuck at Layouts at first too (I refreshed the page after a while and then it quickly installed it), and now with this other site it is stuck again, just keeps installing...
And there was another product where it did the same, I don't remember which one was it.

#328832

Thanks for the Details

This issue happen sometimes due to different reasons, and unfortunately I have seen it suspiciously often lately with exactly Layouts plugin

Manual installation was needed on those sites for Layouts.

Reasons can be, a bad site key, interrupting internet connections, php execution time, etc.

You could try to enable Error Log in WordPress to see if any errors get logged:
https://codex.wordpress.org/Debugging_in_WordPress

The problem is I could never reproduce this issue locally on clean server/WordPress installs, and could therefore not provide our DEVs a correct error report.

I keep an eye on such reports but also I don't see the issue often, and often it's related to temporary internet issues and / or server limitations/issues.

You can try:
1. A new site key
2. Page reload,
3. no other Plugins,
4. no cache,
5. Other browsers
6. If the issue persist, and you can reproduce it with clear steps on clean installs I would appreciate temporary access (WP-Admin and FTP) to your site
- preferably to a test site where the problem has been replicated if possible -
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would additionally need your permission to de- and re-activate Plugins and the Theme, and to change configurations on the site.
This is also a reason the backup is really important

Please don't hesitate to inform me in case the issue persists

Thank you for your patience.

#329026

Thanks for the Details

Unfortunately the password is wrong.

ERROR: The password you entered for the username wpTypes_support is incorrect.

Can you double check it so I can login and see to solve this/report it?

To be sure:
1. On this site, you can not install ANY of the plugins with the installer / commercial tab?
2. This is in a sub-domain?
3. The Plugins are registered?

Please could you provide me the additional Infos?

Thank you for your patience.

#329030
Bildschirmfoto 2015-08-27 um 14.36.05.png

Thanks for the Details

This new Password worked flawlessly.

I logged in, went to wp-admin/plugin-install.php?tab=commercial, checked the Layout Plugin, hit "Download".

That worked on my end.

You can see the screenshot and also control it in your WP Admin.

I have queried it again with the DEV of Layouts, me and him where not able to replicate this neither Locally, nor me on your site.

DEV could not tell me what the issue can be here, unless a Internet / ISP / Browser / Computer issue on the specific user's end.

Please don't hesitate to inform me in case the issue persists and let me know if you have further questions regarding the issue mentioned in this Thread

Thank you for your patience.

#329033

Yes, it works for the second time - but never for the first, and I just thought that may have something to do with the problem in Layouts integration... If you want, I can reinstall the contents and let you do the plugin installation for the first time to see if something changes. But if you are certain that the two are not connected, then we can proceed with the integration.
Actually I believe if you run the installation on the rest of the plugins, you'll have one other (I can't remember which one) that will also get stuck at first. Maybe the developers can check the issue with that one.

#329041

Thanks for the Details

We do have found something meanwhile.

Layout is heavy weight, installing it together with other plugins is creating a "crunching" behavior, even stops sometimes the download.

Refresh the page and repeat the step with Layouts only helps (that also confirms your "the second time it never happens)

Yes this can be a issue later if you think that eventually files can be corrupted during a "crunching" download process.

This is rare, but it can happen.

To solve this, the manual approach is recommended, since it does not happen often, it depends on connection, speed, server, etc.

I would suggest (to be sure) to install Layout manually in this case.

That will for sure avoid any corrupted files.

Then, it should work flawlessly

Please don't hesitate to inform me in case the issue persists and let me know if you have further questions regarding the issue mentioned in this Thread

Thank you for your patience.

The topic ‘[Closed] New settings popup appears BELOW already open popup and can't edit content cell’ is closed to new replies.