Skip Navigation

[Resolved] New Post Notification Emails are not functioning

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Tagged: 

This topic contains 41 replies, has 4 voices.

Last updated by Beda 2 years, 4 months ago.

Assigned support staff: Beda.

Author
Posts
#1243134

I am trying to: send success notifications via email when new posts are submitted

Link to a page where the issue can be seen: hidden link

I expected to see: I expected to get the notification via email

Instead, I got: No email arrives.

#1243336

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Email2.JPG
email.JPG

Hello,

Thanks for the details, I can log into your website, but I see different problem:
Email: Not an authorized, work email.
See screenshot: Email.JPG

And I have tried to check the form "Try Nutanix Email Entry" settings, but it seems that you are working on it:
See screenshot: Email2.JPG

I assume you are using custom codes to customize the email validations, I suggest you check these:
1) In case it is a compatibility problem, please deactivate all other plugins, and switch to wordpress default theme 2019, deactivate all custom PHP/JS code snippets, and test again

2) Also check if there is any PHP error in your website:
https://toolset.com/documentation/programmer-reference/debugging-sites-built-with-toolset/

#1243349

Sorry - I should have pointed that out. There is a function in functions.php for the child theme that filters for an array of domains from which emails are accepted. The promotional program is only for employees of a particular company and you will need to add your email domain to that array in order to avoid that message. The Toolset staff helped me with that function.

There are no console errors and the PHP is working. In fact, the email notifications stopped working with the most recent Types update.

Also - please feel free to take over editing anytime you see the warning that someone else is working on it. I am the only one & the site is not yet live. I tend to get too many tabs open when working in Toolset!

#1243411

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

To avoid any other conflict, I am downloading the duplicator package you provided above, try to duplicate the same problem, will update here if there is anything found.

#1243457

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

emails.JPG

I have tried your duplicator package in my localhost(without deactivating plugins or switch theme), the emails works fine, I can get the both of email notifications without any problem, see screenshot emails.JPG.

So it might be a server problem, I suggest you try these:
1) Install the plugin "WP Mail Logging" in your website:
https://wordpress.org/plugins/wp-mail-logging/

2) submit the form, and test again, check if the emails are sent by wordpress, if the emails are sent, then you will contact your webserver provide for this problem, your webserver might not be able to send the emails.

#1244184

Thanks, Luo. I've installed & configured the WP Mail Logging plugin and followed the instructions. Emails are now arriving, however, the success email notification is not properly parsing the Fields and Views short codes. I should see a link, in the email like: hidden link where the last 10 characters are a random string used to uniquely identify registrants. That random value is generated by JavaScript and inserted into a hidden field in the form. It is being created and saved to the database successfully, but the CRED form is failing to insert it at the end of the URL.

When I look at your screenshot, I can see that it has successfully attached that string to the link in your email. Can you help me hunt this issue down?

#1244216

I think there are more significant problems here. I am registering with both pm@pmconsulting.biz & junk@pmconsulting.biz using the entry page at trynutanix.com/email-entry The first time I register, I receive the success notification email, but CRED is not properly attaching the [random_string] field to the end of the URL in that email.

If I delete the posts created by that form and then re-register at trynutanix.com/email-entry CRED never sends the success notification again. There is no record of it in the SMPT Email log either.

I have done everything I can think of but I cannot understand why success emails are not sent dependably and why CRED is failing to interpret and replace Types shortcodes properly. I have devoted many days attempting to just get basic functions working. I am really in trouble with my customer if I can't get Toolset to function properly.

I have provided all the access information requested, along with any additional access and tools that I thought you might need. You have a full copy of the entire site. You seem to have it successfully working on a different server. I have followed all your suggestions but nothing seems to be making any difference.

For some additional background, this entire site was and still is functioning properly under a different domain - zerotoprotect.com. I simply made a copy of that site using the Updraft plugin and restored it to the new domain trynutanix.com. I then began modifying Toolset post types, fields and post forms for the new domain. As soon as I was far enough along to text registration, I began to see these issues. I used a tool to scan the entire database for the old domain and changed it to the new domain. It did find quite a number of additional changes after a successful restore by the updraft plugin, but I believe those were just orphaned records in the post meta database, and should not affect the site operation. I've gone through settings and configuration for each and every plugin, but I am still left with a non-functioning copy of a functioning Toolset website.

#1244429

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

email3.JPG

I have tried it in your website, with below steps:
1) Dashboard-> Filtered Emails,
Trash and Delete Permanently the post "pm@pmconsulting.biz",

2) Goto URL
hidden link
fill the same email address: pm@pmconsulting.biz
submit the form

3) Dashboard-> Post SMTP-> Email Log
I can see the email was sent, see screenshot email3.JPG

So email notification settings does work in your website, can you confirm it?

For the new problem: attaching the [random_string] field to the end of the URL
I have checked these:
Dashboard-> Filtered Emails, edit the new post "pm@pmconsulting.biz":
The field "Random String" is empty, so it conducts the problem you mentioned above.
the shortcode [types field='random-string'][/types] in the email notification body will display empty.

And it is your custom JS codes problem, I have edited the post form "Try Nutanix Email Entry":
hidden link
click "JS editor", replace the JS codes from:

$('input[name=wpcf-random-string]').val();

To:

$('input[name=wpcf-random-string]').val(random_string);

Please test again, check if it is fixed.

#1245655

I fixed the JS error, but email is still not functioning. I am doing exactly what you are doing. I am deleting all Filtered Email posts and also emptying the trash to permanently delete them.

I wait for a good period of time - 10 minutes or more. Than I visit nutanix.com/email-entry and re-register using any of the approved emails. The page responds with the success message. I can see that the new post has been created along with the correct random string generation.
BUT NO EMAIL IS SENT, GENERATED, LOGGED OR OTHERWISE HAPPENS. I believe there is a problem with emails that have previously been processed by Toolset. If I delete the entire site & restore it I will receive the first AND ONLY THE FIRST success message email. After that, it never sends a subsequent email to the same address for the entry page. It only can happen once and NEVER AFTER THAT FIRST TIME.

You will see a Filtered Email with the email address of pat@bongo.cc. Check the time stamp for the creation of this record. Check that it has a random string field that is populated. Now, check the email log. THERE IS NO OUTGOING SUCCESS MESSAGE. IT FAILED. IT DOES NOT WORK.

I need it to happen after every submission as the documentation seems to indicate it should. I need this to be reliable and dependable. I have business customers who need this to function every time. It is urgent.

#1245672

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

email4.JPG

Thanks for the details, I have tested it in your website again with my Chrome browser, using the same steps, login or logout using email address "pat@bongo.cc", but I do see it is in email logs:
hidden link

See screenshot: email4.JPG

Can you try these:
1) Clear your browser cache and test again
2) Test it with another web browser,

#1245891
Screen Shot 2019-05-20 at 7.57.36 AM.png
Screen Shot 2019-05-20 at 7.56.44 AM.png

User with email joe@zingintegratedmarketing.com just went through the same email registration process. The Filter Email post was correctly created but notification was never sent. Cred form was submitted at 7:40 am CST, about 20 minutes ago.

#1245901

Your are confusing the new user registration message with the one that I'm having problems with. There are 2 notifications when a user registers. One just notifies that admins and the other is the important one that gets sent to the person who registered and which contains the link needed to complete the process. That is the one that never gets sent.

Perhaps you are too busy to fully focus on this issue? Please take a more careful look or have someone who can fully address this issue handle it.

#1245924
Screen Shot 2019-05-20 at 8.18.50 AM.png
Screen Shot 2019-05-20 at 8.19.21 AM.png
Screen Shot 2019-05-20 at 8.13.16 AM.png
Screen Shot 2019-05-20 at 8.13.31 AM.png
Screen Shot 2019-05-20 at 8.11.34 AM.png

I registered using the email address pat@bongo.cc. I did that at 7:40 am, CST. I received TWO copies of the email with the correct link at at 8:04 am CST. Those emails were timestamped 2:26am CST and 2:31am CST. The email log shows that these emails were both sent at those times which is 8-1/2 HOURS BEFORE THE REGISTRATION HAPPENED!!

Both the server time and word press time are currently 8:19am CST

Any time any user completes a CRED form that contains any notification, that notification should be sent IMMEDIATELY and any and all timestamps must be the same as when that event took place. That is not happening correctly. Those notifications are being sent between 20 and 60 minutes LATER and the time stamps are then being DECEPTIVELY CHANGED to times which are more than 6 HOURS PRIOR to the actual events.

This is legally dangerous and will guarantee that I and all of my clients will immediately remove Toolset plugins and replace them with software that is supported and can be trusted.

#1246271

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

http1.1.JPG
email5.JPG

Q1) One just notifies that admins and the other is the important one that gets sent to the person who registered and which contains the link needed to complete the process. That is the one that never gets sent.

Please check my answers above:
https://toolset.com/forums/topic/new-post-notification-emails-are-not-functioning/#post-1244429
screenshot:
hidden link

In my tests in your website, the email does send to the the person who registered: pat@bongo.cc

If you want to send to admin users, you will need to edit the post form:
hidden link
in section "E-mail Notifications", enable option "Send notification to a specific email address", input your admin user's email address.

I have tried it again in your website, it works fine, see screenshot email5.JPG

Q2) Those notifications are being sent between 20 and 60 minutes LATER and the time stamps are then being DECEPTIVELY CHANGED to times which are more than 6 HOURS PRIOR to the actual events.

In my test in your website, after submit the Toolset post form here:
hidden link

The email logs are added here immediately
hidden link
See screenshot in Q1)

And the email should be able to send to email box immediately, unless there is email server problem in your website.

So I don't see same problems as you mentioned above.

And I have seen another similar email notification report related with HTTP2 protocol, please try these:
Test with firefox browser in your computer, open URL hidden link, press F12 key, switch to network tag, check if you are using http2 protocol to do the request.

See screenshot http1.1.JPG

#1246739
Screen Shot 2019-05-21 at 3.00.35 PM.png
Screen Shot 2019-05-21 at 3.00.07 PM.png

First, I filled the CRED form on the /email-entry page at 1:17pm on May 20. The post was finally published and the notification email sent, according to your image and my verifying the same, at 1:10am, May 21. NEARLY 12 HOURS LATER. IT IS NOT SENDING IMMEDIATELY. IT IS NOT FUNCTIONING PROPERLY!

Second, you are again just contradicting me, rather than reviewing what I have proven and just testing it yourself. THE PROBLEM CONTINUES TO HAPPEN. I just registered a totally new email: tp@bongo.cc. I did it at 2:43 pm, May 21. NO CONFIRMATION EMAIL. NOTHING IN EMAIL LOG. NOT WORKING!!!

SEE IMAGES: Email registered at 2:48pm. Email log at 3:00pm DOES NOT SHOW ANY NOTIFICATION for tp@bongo.cc. NOT WORKING!!!!!

How many times do I have to keep proving the same thing before you actually start to look at the problem??