Skip Navigation

[Closed] Navigation submenus fail to appear under Toolset Bootstrap Theme.

This support ticket is created 7 years, 8 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 8:00 – 17:00 8:00 – 17:00 8:00 – 17:00 8:00 – 17:00 8:00 – 17:00 -
- - - - - - -

Supporter timezone: America/Sao_Paulo (GMT-03:00)

This topic contains 11 replies, has 2 voices.

Last updated by Adriano 7 years, 6 months ago.

Assigned support staff: Adriano.

Author
Posts
#289528

I am trying to: Navigate to a submenu when visiting the below website

I visited this URL: hidden link

I expected to see: Expect to see submenus when hovering over say "Buys & Sellers", or "Loan Center".

Instead, I got: Nothing. Even when I click or double click the menu items as described. No sub-menus appear as expected. Switch out to nother Theme, the submenus will show up again.

#289722
Captura de Tela 2015-03-16 às 14.25.52.png
Captura de Tela 2015-03-16 às 14.24.36.png

Hi David,

I couldn't reproduce that issue on my localhost, see the attached image.

Do you have sure that both option in Menu Settings are OK? See the attached image.

If you still can't see the submenu level we should look for compatibility issues. Please do that:

1. Deactivate all plugins, except the Toolset ones
2. Select a default WordPress theme
3. Try again

#290029

Hi Adriano,

I have identified a plugin which when activated, Toolset Bootstrap Theme is not able to display navigation submenus. But that plugin is essential to me - I must keep it activated. What can I do to make Toolset Bootstrap Theme compatible with that plugin?

David

#290857

Hi David,

I can open a compatibility report, so our development team can take a look at it. Which plugin is that? If you it's not free, could you send me a version by email? You can send it to adriano.f@onthegosystems.com

Please let me know if you are satisfied with my reply and any other questions you may have.

Regards,

Adriano Ferreira

#290919

Hi Adrino,

The plugin is called Optima Express, and there is actually a free version available from wordpress plugin depository. Just to see if the free version would exhibit the same problem the the navigation submenu visibility, have actually downloaded it to hidden link and tested it with the Toolset Bootstrap theme. The problem exist indeed - i.e. the navigation sub-menu does not show up under the Toolset Bootstrap theme but will show up when switched to any other theme.

If Toolset support wish to access the above mentioned test site, just email me and I shall provide the admin user name and password for the test site.

Regards,
David Ling

#291107

Hi David,

I'd ask you a little more. Could you send me a duplicator package (wordpress.org/plugins/duplicator) of your site? With that, our development team could work on your environment but in localhost, much more easily to debug and implement fixes. You could send that to adriano.f@onthegosystems.com

#294382

Hi Adriano,

I have just received a message from Toolset's "Support clean up robot", saying there has been waiting for feedback for 2 weeks now, and that if I do not add a message my issue will be assumed resolved. This is outrageous.

On 3/25/15, 2 days after your request on 3/23/15, I sent you an email giving you what you have asked for, and more. Did you not receive it? I did not hear back from you after that email.

Then on 4/5/15, I emailed you again to inquire. I haven't received a response to that email either, but instead 3 days later Mr. Support Clean Up Robot emailed me if my issue has been resolved. Not it is definitely not, and I need to have Toolset get it resolved otherwise I could not proceed to start using (or learning to use) all those nice Toolset plugins that I have bought.

So I am making this response on the Support forum in order to keep my issue alive.
In addition I have just forwarded a copy of the email that I sent to you on 3/25/15. Please acknowledge receipt of my email.

David

#294986

Hi David,

My apologies the long delay. We are working in a new version of Toolset Bootstrap theme, we are still debugging that issue and will include that fix in the next release of it.

#295062

Hi Adriano,

There seem to have been some mis-communication between us. I have frozen my effort to use or learn Toolset thinking the navigation menu issue will be resolved very quickly. Now that you tell me it wont' be resolved until a new release for the Bootstrap Theme is available, could you give me an estimate when this release may be expected? Would it be weeks, or months?

David

#295463

Hi David,

I'm sorry about that. I've talked with our development team, the new fresh version of Bootstrap is almost ready, but it won't fix that issue, because it's not coming from us, but from Optima Express. If you see the JS/CSS console bar, you'll notice that there are some warnings that should be fixed to make this plugin works with any other theme:

Consider using 'dppx' units, as in CSS 'dpi' means dots-per-CSS-inch, not dots-per-physical-inch, so does not correspond to the actual 'dpi' of a screen. In media query expression: only screen and (-webkit-min-device-pixel-ratio: 2), only screen and (min-resolution: 144dpi)
leaflet.js?ver=4.1.1:6 Consider using 'dppx' units, as in CSS 'dpi' means dots-per-CSS-inch, not dots-per-physical-inch, so does not correspond to the actual 'dpi' of a screen. In media query expression: (min-resolution: 144dpi)
leaflet.js?ver=4.1.1:6 Consider using 'dppx' units, as in CSS 'dpi' means dots-per-CSS-inch, not dots-per-physical-inch, so does not correspond to the actual 'dpi' of a screen. In media query expression: (min-resolution: 144dpi)

#300962

This is very, very annoying.
Wordpress website says Toolset plugins has upgrades available, but I am unable to download and upgrade. Says "failed" when I tried.
And then I tried to start a new support request to get help. I logged in to Toolset website, under Tech Support click "my topics", but toolset website does not consistently provide the "form" for me to submet a new support request. When it does provide the form once to submit a new help request, it presented me with a dozen previously resolved help sessions from other users, I clicked them all off as not relevant to my issue, but at the end was not given the opportunity to enter my issue. I started over, and this time, can't even get the form to show where I may submit a new help request. Have tried several times.

So I am foreced to use this thread - from a previously submitted help request that hasn't close out, to submit my new request for help.

My new request is again, unable to downloand and install all the Toolset plugin components, except for Type which does not require subscription.

#301923

I need to request temporary access (wp-admin and FTP) to your site in order to be offering better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

The topic ‘[Closed] Navigation submenus fail to appear under Toolset Bootstrap Theme.’ is closed to new replies.