Skip Navigation

[Resolved] Missing Results in View

This support ticket is created 3 years, 7 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Beda 3 years, 7 months ago.

Assigned support staff: Beda.

Author
Posts
#1194508

Looks like after I updated, there is missing results under the views on hidden link

#1194633

I see that View lists "Tours" and orders the output by a custom field "Tour Start". Also, the View features a Query filter where again the field Tour Start is used and 2 more Front End Filters (those should interfere in the initial output, but the Field query does, as it's a Query Filter opposed to Front End filter, which the user can choose).

In the View loop, there is an Elementor Template and a content template, which is not suggested.
We suggest to either use Content Templates, or Elementor ShortCodes that insert Elementor Templates (if used directly in the View loop.)
Especially the Elementor Template within the Content Template will not work.
It's explained here:
https://toolset.com/documentation/user-guides/using-toolset-with-elementor-page-builder/create-templates-for-custom-post-types-with-elementor-and-toolset/#limitations-when-using-elementor-and-toolset-templates-together

Now, the Post Type "Tours" has 133 items, the View outputs 66, which should be about right since the Filter says to remove all that are starting before today, and show only the ones starting after today.
I did not check all posts, of course, but the ones I did, feature an older date than permitted by the query and hence, are removed.

Can you indicate me precise posts that should appear, but do not?