Skip Navigation

[Resolved] Many to Many relationships not working correctly after updating to 3.0 or 3.0.1

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Luo Yang 1 year, 8 months ago.

Assigned support staff: Luo Yang.

Author
Posts
#1416981

I am trying to: Update to version 3

Link to a page where the issue can be seen:
If you go to : hidden link you can see 5 posts. Two of them have Jason Shim as presenter. If you click on Jason Shim it will show you his page. Before the update tit only showed his two posts. Now it shows everything.

The same is for Publications. On Publications we got pub-authors. If you click on a pub-author under"by:" Then it will take you to the authors page but will show all posts instead of his/her posts

I expected to see:
That for promising practices and for publications if i click on the author/presenter i will only see his/her posts.

Instead, I got:
All the posts.

In the back-end we use updraftplus for backups. If i restore the plugin folder back to before the update everything is working fine. If i update toolset views to 3.0 or 3.0.1 then it's not working anymore.

If you want to restore the plugin folder then go to settings > updraftplus backups > and restore the plugin folder from dec 12.
(JUST THE PLUGIN FOLDER PLEASE)

Guido

#1417641

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Dear Guido,

Thanks for the details, I can see the problem in your website, the problem is abnormal, please check these:
1) In case it is a compatibility problem, please deactivate all other plugins, and switch to wordpress default theme 2020, deactivate all custom PHP/JS code snippets, and test again

2) Also check if there is any PHP/JS error in your website:
https://toolset.com/documentation/programmer-reference/debugging-sites-built-with-toolset/

4) If the problem still persists, please provide database dump file(ZIP file) of your website, I need to test and debug it in my localhost, thanks
https://toolset.com/faq/provide-supporters-copy-site/

#1427873

Hi i tried option one and two but didn't resolve anything.

I tried duplicator but the site is over 500mb. Will try it later and provide everything in the beginning of January.

Thanks
Guido

#1430793

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

You can put the database dump file in your own google drive disk, and share the link in below private message box, then update here.

I have marked this thread to waiting for feedback status, and enabled the private message box again.

#1436309
#1437085

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, I am downloading the files, will update here if there is anything found

#1438153

Oke great! Thanks.

#1440567

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

t1.JPG

Sorry for the delay answer, I can see the problem with your duplicator package, then I have tried the same setting in a fresh wordpress installation, it works fine.

Please try these in your website:
1) Upgrade to the latest version of Toolset Views plugin
2) Create another post view, for example "Good Ideas View Presenters 2", with same filter settings, use this new view to replace old problem one, and test again.

I have tried it in your database dump file, it works fine, see screenshot