Skip Navigation

[Resolved] Manage Relationship access

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by romanF 1 year, 2 months ago.

Assigned support staff: Shane.

Author
Posts
#1693009

I have two custom types "Aktuere" and "Angebote". The two are in a one-to-many relationship (One "Akteure" to many "Angebote").

I have limited the access rights for users but they should be able to set the relationship between their own "Aktuere" and their own "Angebote". I can't find where to set these rights for this specific role.

Can you support me on this quest?

Thank you

#1693055

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Screenshot 2020-07-09 at 9.42.40 AM.png

Hi Roman,

Thank you for getting in touch.

Are your user's creating the relationships on the frontend ? Or is it done on the backend.

The reason is because on the frontend you have the option to filter the relationship field so the user will only see the parent posts they created. See Screenshot

You have the option in our toolset forms to "Get only options by the current author".

Please let me know if this helps or if further clarification is needed.

Thanks,
Shane

#1693085
user_view.jpg
admin-view.jpg

Thank you Shane for your fast reply.

This is done in the backend. And it looks like this (admin view) as an admin (see the two buttons to connect to an "Akteur".

But these two buttons are missing if I am logged in as a user with a different role. And I can't find the option to get theses buttons for the user.
Ideally, if the buttons are there, they would only show their own content.

Thank you.

#1693109

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Roman,

This is perhaps because of your permissions that were set for the post types, Ensure that the user has Read/Edit access to the parent/child post type.

Secondly if you're doing this through the backend then you won't be able to restrict the user to only seeing their posts without the use of custom coding.

Unfortunately such custom coding would be out of the scope of our support forum. The only provision we have for this is to do it through the frontend with our Forms plugin.

Thanks,
Shane

#1693177

Thank you Shane,
can you guide me to the correct backend right setting for this feature? I can't find the parent-child restriction in the access rights settings.

#1693353

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Roman,

can you guide me to the correct backend right setting for this feature? I can't find the parent-child restriction in the access rights settings.

You are not able to do such restrictions on the backend. It is only possible to restrict by the Current user on the Frontend Only using our Forms plugin.

If you want the guidelines on how to do this on the frontend I can give you that but its not possible to do on the backend.

Thanks,
Shane

#1694489

My issue is resolved now. Thank you!

#1702711
zugehörigkeit.jpg

I changed the system now to the frontend. But it still shows all the "akteur" and not just the ones from the current user. Sadly I could not figure out where the settings are that you showed on the screenshot. I do use a user content form and the last option of this is to select the parent (akteur) to this child (angebot). (See screenshot, it should only show one option there)