Skip Navigation

[Resolved] Make page unaccesible through url?

The Toolset Community Forum is closed, for technical support questions, please head on to our Toolset Professional Support (for paid clients), with any pre-sale or admin question please contact us here.
This is the community support forum for Types plugin, which is part of Toolset. Toolset is a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients and people who registered for Types community support can post in it.

This topic contains 6 replies, has 2 voices.

Last updated by thomasS-11 6 years, 11 months ago.

Assigned support staff: Luo Yang.

Author
Posts
#271894

Is it possible to make a page "unaccesible" by URL? so if i make a custom post type that i only want to use in views, without having to worry about others can see the post's, and getting crawled by Google..

#271965

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I suggest you try Access plugin, disable the "Read" ability for guest user and other user roles.

More help:
Limiting read access to specific content
https://toolset.com/documentation/user-guides/limiting-read-access-specific-content/

#272022

then the visitor cant see queried fields from the disabled post type?
i want to use the post types and they should be able to see it in front end.. i just dont want the pages to be public if im using it for i.e. CRED bookings that shouldnt be public..

#272201

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

If you disable the "Read" ability for guest user and other user roles, the visitor can not see the it within the page/post URL, and you will be able to display all custom fields within Views.

Google crawler is a guest user, If you are going to disable guest read ability for all posts of your custom post type, please try:
Access Control for Standard and Custom Content Types
https://toolset.com/documentation/user-guides/setting-access-control/

#272442
Skærmbillede 2015-12-30 kl. 02.18.43.png
Skærmbillede 2015-12-30 kl. 02.18.39.png
Skærmbillede 2015-12-30 kl. 02.18.33.png

Hi. Sorry but no.. i have already set it, and i tried restoring and setting it to above settings (again) and i still get "No post/results found" when in incognito mode, but when i switch to logged in window, i can see the queries.. i have attached screenshots below.

I know Google is a guest as everyone else not logged in, but thank you 🙂

#272519

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

You are right, I have been able to duplicate same problem in my localhost, Views won't display the post of which is hidden for current user in Access.

If the post type is created with Types, please try this, Goto your WP admin side:
Access-> find post type "Slider", disable the option "Managed by Access"

Types-> Types & Taxonomies-> Edit Custom Post Type "Slider"
in section "Options", disable option "publicly_queryable", and test again.

More help:
http://codex.wordpress.org/Function_Reference/register_post_type
publicly_queryable
(boolean) (optional) Whether queries can be performed on the front end as part of parse_request().
Default: value of public argument
Note: The queries affected include the following (also initiated when rewrites are handled)
?post_type={post_type_key}
?{post_type_key}={single_post_slug}
?{post_type_query_var}={single_post_slug}

#272946

Very good. Thanks alot.

Could you make the dev team look into the error you receive when you visit a non-queryable page?

Fatal error: __clone method called on non-object in /data/home/carpedie/public_html/wp-content/plugins/cred-frontend-editor/classes/CRED_Helper.php on line 1764

Here is a link: hidden link

The forum ‘Types Community Support’ is closed to new topics and replies.