Skip Navigation

[Resolved] Link to spinner at hidden link is left in my site, breaking SSL

This support ticket is created 5 years ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Christian Cox 4 years, 10 months ago.

Assigned support staff: Christian Cox.

Author
Posts
#572219

I am trying to: Create a site based on a reference site and secured with https

Link to a page where the issue can be seen: hidden link

I expected to see: a fully secure site

Instead, I got: some http links to ref.wp-types.com in serialized array post_meta data that is output in the page source like this:
hidden link

Shouldn't these point to a local instance after installing the reference site? They also need to be // or https for my SSL to be intact.

#572223

Site says it is secure now so apparently this is not interfering with SSL success. Still wondering why it is in the page at all though.

#572245

Hi, I see the same thing occurring when I install the Company reference site. As a test, can you edit all your Views and resave them? In my local instance, this was enough to update the paths to the spinner images. If that resolves the path issue, I can report this as a potential issue to the reference sites team.

#572260

I edited and saved every layout, view and content template. Still seeing the ref.wp-types.com links in the source.

#572278

Okay I'd like to take a look in your wp-admin area to see if I can resolve this for you. If not, I'll need to create a site clone that I can use for further testing without breaking your site. If that's okay, please provide login credentials in the private reply fields here. I will install the Duplicator plugin temporarily to create the site clone.

#572313

I see, the trick is that you have to use the Pagination Settings panel to select a different pagination setting that triggers an update of the spinner. I chose "Pagination enabled with automatic AJAX transition" and clicked away to trigger an autosave, then switched it back to No Pagination. On the homepage, I no longer see the ref.wp-types.com domain showing up anywhere. I have updated the other Views as well. Can you confirm the ref domain is not longer appearing on the site?

#573699

In the meantime, I have escalated this issue to our 2nd tier support team, and they have passed the information along to our developers. I will continue to update you here as I receive more information. For now, the workaround is as I described above.

#589484

Hi, the latest version of the Toolset Framework Installer plugin an reference site downloads include a permanent fix for this problem. Please update to the latest versions before attempting a new reference site installation and let us know if you are still experiencing errors. Thanks for your patience while we worked to resolve this SSL issue.