Skip Navigation

[Closed] Link to CRED Edit not working for sub site

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 0.75 hours from now. Thank you for your understanding.

This topic contains 23 replies, has 2 voices.

Last updated by Beda 6 years, 3 months ago.

Assigned support staff: Beda.

Author
Posts
#297738

I am trying to: add a view with a list of all portfolio-items (Theme Enfold) - but the edit feature does not work. Instead of the edit form, I do get a display of the content

I visited this URL: hidden link

I expected to see: The edit form to edit the content

Instead, I got: just the displayed version.

When I go to my Sites page at Toolet, I don't see any component installed. I have seen the "Commercial" tabs once where I registered Toolset with the key related to "synergic.nl". However, I don't see this "Commercial" tab anymore. Please explain how I need to register the toolset components for my sub sites, based on directories

The strange thing is that the edit forms is working for another sub site.

I have updated all the forms manually.

Is the non-working feature of the cred-form related to the registration?
How to I handle the registration for my sub sites?
Why don't I see these details at my site info within the Toolset portal?

#297798

Thank you for contacting us here in the Support Forum

I will take care of your ticket.
Could you please share your Debug Informations with me?
https://toolset.com/faq/provide-debug-information-faster-support/

I see you experience different issues.

May I kindly ask you please to open a new ticket for your additional questions?
This will help other users with similar problems to find solutions when searching the forum, and permits the supporters to concentrate on one issue at a time.
If this is OK with you, we would handle issue #1 in this Thread:

?Link to CRED Edit not working for sub site??

I will shortly mention a few things related to the Commercial Tab and the Info in the Toolset Account:

- The "Commercial" tab is not present in 1.6.x, but it is resolved in the development version already.
In the mean time, you can find the same page by navigating to Dashboard > Types > Installer

- The site key is only used for updates and you dont loose any functionality by not having it registered.

- You might need to unregister and re-register once your Plugin(s) for seeing the correct info in your Tooslet Account > Sites

Now about the more critical issue of this Thread:
?Link to CRED Edit not working for sub site??

1. I have added a simple CRED Edit Form to my Local test site, and displayed a Link to it on a Post.
This works flawlessly on my test site.
The link is preset, and on clic the Form is displayed correctly.

Please make sure to have added it into your Content Template (or View) wehre you want to render it on your sub site.

If you want to enter only the Link to the CRED Edit Form, you can choose that with the CRED Form Wizard.
https://toolset.com/documentation/user-guides/creating-cred-forms/

To check the issue and see at the problem closer, I would need to request temporary access (WP-Admin and FTP) to your site
- preferably to a test site where the problem has been replicated if possible -
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private which means only you and I have access to it.

?? Please backup your database and website ??

✙ I would additionally need your permission to de- and re-activate Plugins and the Theme, and to change configurations on the site.
This is also a reason the backup is really important

✙ Please could you also indicate me the correct path to:
- the CRED Form in Question
- The View wehre inserted it
- The Front end where it should display the CRED link-to Form
This way I can locate the content faster to troubleshoot it

Please could you provide me the additional Infos,
and as well permit me to perform the required steps?

Thank you

#298121

Thanks for the Details

I tried to Login to the WP Admin Area, but somehow the Login Details don't work for me

I see that you seem to have provided 2 different kinds of User Names, but neither combination of the provide login details seems to work

Please could you provide me access details by formatting them like this:

WP User Name:

user_name_here

WP User Password:

your_password_here

I will then have a look at the setup and see wehre the problem could be.
== >I understand I can make tests as needed, as you have made a full backup of the DB

Please could you provide me the additional Details?

Thank you

#298385

I had some issues with CLEF and Brute Protect - Now I'm finally able to login with the user ...

However, now I don't have the opportunity to add any private details. Can you please resolve this for me again.

#298626

Thanks for the Details

I apologize the late reply.

I unfortunately don't use CLEF myself, and I can't share a Email with you , as the only way to communicate is this Forum. It is, due to Company Policy, not allowed to me to share Email Adress(es) in the Forum.

I will now reactivate the Private answer Forum, in oder for you to provide me new access details.

Please be sure that I can log in with the default WP Admin Details.

If this is not possible to implement, I would need a sites snapshot if possible.
We usually recommend the free Plugin "Duplicator" for this porpoise.

If you already know how Duplicator works
(http://wordpress.org/plugins/duplicator/),
please skip the following steps and just send me the installer file and the zipped package you downloaded.

★ Duplicator Instructions
hidden link
Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)

?? IMPORTANT ??
Remember to create or keep an admin account for me before creating the snapshot, or I won't be able to login. You may delete the new admin account once the snapshot has been built.

I will enable your next answer as private so you can provide me the information securely.

Please could you provide me the additional Infos?

Thank you

#301428

Thanks for the Details

Unfortunately now I receive a ERROR 403 on the Login URL:

Forbidden
You do not have permission to access this document.
Web Server at synergic.nl 

I do also see (weird) that you seem not to have your Toolset Plugins installed on the site where you sent me the Debug Infos from.

Only 2 Plugins are listed, "WP Health System" and Password Protected".

Could you try to manually reinstall them, so we can make sure no files are corrupted and all is up to date?
(If you haven't already done so)
The steps would be outlined here:
https://toolset.com/documentation/installation/

I then also suggest to make sure you use the original (no child), and freshly from the Authors Download Site downloaded Enfold Theme, to test it again.
(If you didn't already)

Please also try with different constellations, such as CRED Only, or CRED with other plugins enabled.

It might be a conflict with Enfold but could also be a "co-play" of all factors together.

As workaround to the Duplicator snapshot, a Database Dump might work, as we have Theme Enfold in our Testing Theme's repository, I can get it from there and test your Database on a new FTP with the Theme Enfold and get back to you with my findings.

If you can manage to grant me the access, I am also happy to look at your environment.

Thank you for your cooperation.

#301784

Thanks for the Details

I have tried a few things on your site there and can at least confirm that your CRED Form is correctly working in this cases:

1. Directly inserted to the page (no "edit" link, but the form itself)

2. If the Edit link is inserted in the post itself, and in the view,
then the edit link in the view works perfectly, and leads to the Edit form.

The downside is, you have the same edit link as well in your post by this, which could be hidden, but thats not how it should be.
Th Upside is we know that the form itself is correctly set up.

What I require to proceed the troubleshooting is to ask you if you gently could update your Enfold + Builder-Cohen (not sure which one you use), and WordPress itself.

I also see that you seem to use a CHILD Theme of Enfold, in this case, could you give it a try with a freshly downloaded Original Theme of Enfold?

Then, in case the issue persist, it would be necessary to "isolate" the issue by disabling all NON Toolset plugins and try again.

I see you are using security plugins, which can (they don't have to) interfere with Plugins like CRED.

In case after all this steps the issue still remains, I think we will need to perform tests on our test Servers, to see where the issue is coming from.

Please could you confirm me the additional Details?

Thank you

#301947

I have tried the following after updating WP 4.2.2 and Enfold.

- Add the creed edit to a single post => working ok - not what I want 🙁

- Deactivate all plugins - still not working edit from the view

- Moving to Enfold instead of Child theme - no change in behaviour.

Very strange - I'm looking for a solution as I have quite some Toolset/CRED/Enfold currently in development!

Looking forward to your response

#302308

I apologize deeply the inconveniences you are facing due to this issue. I will try to help you as fast and effective as possible, so you can go on with your project.

I have been able to replicate this locally (using a Copy of the Enfold Theme),
and even found a older Thread mentioning this very issue, which unfortunately wasn't ever escalated because the Client decided to move away from Enfold.
https://toolset.com/forums/topic/how-do-i-propsely-attach-a-cred-edit-form/

I will now escalate this issue to the DEV Team, so they can check if it's a issue on our Plugin, or if we need to contact the Enfold Theme Author to solve this.

In case we need ensure that this Theme is made compatible with CRED, we need to contact the Theme's author and work with him on resolving the issue.

Could you please provide a link to your Theme's download (or purchase) page as well as contact information (email as example) to the Theme's author so we can contact him?

We will then contact the author.

Please could you provide me the additional Infos?

Thank you

#304169

Just to inform you that I'm not getting any email notification when you update this thread.

#304191

Thanks for the Details

Could you perhaps send me contact details to the Theme Authors?

We don't need your personal login details to the Download site, just the link to the site where you download it, and probably The theme Author has a contact email or website where we can get in touch with him, without logging into your account?

This would be great.

Meanwhile, our DEV Team has found a previous CRED version where the problem is not present, but I can t provide you that CRED Version because it is obsolete and other BUGS would re-appear if you would use it.

I also recognized lately that it seems Enfold Theme has introduced some issues with WordPress 4.2

I am seeing this notice:

Notice: register_sidebar was called incorrectly. No id was set in the arguments array for the "Footer - column4" sidebar. Defaulting to "sidebar-9". Manually set the id to "sidebar-9" to silence this notice and keep existing sidebar content. Please see Debugging in WordPress for more information. (This message was added in version 4.2.0.) in .../wp-includes/functions.php on line 3560

This seems related to Enfold, as it only happens on activation of that theme.
Can you confirm you see the same error?

Meanwhile our DEV will debug this further and I will update you here if we have new findings.

I also suggest you contact Enfold Personally about this matter. This might expedite the process.

Thank you

#304218

I would need a contact info to the Author, such as a email, or perhaps he has a Support Site (public) where we can contact him.

I am not sure if you provided them with your last message, but nothing came through, I only see your question if we have enough details.

A Email would be great. Usually Theme Authors have them published in the site where you download the Theme.

It can be any form of contact, best is Email, but it can also be other kind of communication form.

Usually, taking as example Theme Forest Website Template seller, you can see the contact email on the right side sidebar when looking at the purchase page for your Theme.

It would be useful, so we can contact him, if necessary.

Thank you

#304493

Just to inform that the combination of Enfold and CRED 1.2.4 is working fine!

In that environment, the EDIt form will work fine.

#304556

I have created a ticket also within the Enfold Support system to ask for the contact details.
wordpress@kriesi.at should work also.

#304574

Thanks for the Details

I have forwarded this to the 2nd Tier Support as well, I will update you here as soon I have news about this.

Thank you for your great patience on this.

The topic ‘[Closed] Link to CRED Edit not working for sub site’ is closed to new replies.