Skip Navigation

[Resolved] issue with button :visited and :focus psudeo classes

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Raja Mohammed 6 months ago.

Assigned support staff: Raja Mohammed.

Author
Posts
#1839409
buttonbug.png

your button block has NO color setting for visited active focus, so it looks like the focus is inheriting the bg style from the hover and the visited from the regular color setting. So take a situation where your button text color in normal state is the same color as your hover background color. then have a link set to open in a new window. Clicking on the button will now make your text dissapear with no way to fix it with the block settings.

#1839969

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello there,

Thanks for reporting i am able to reproduce the issue, I am escalating this to the second tier. Meanwhile you can override the styles by adding a custom css class to the button block.

Regards
Raja

#1845549

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

The issue has been escalated i will update here once i have anything to share with you.

#1917365

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

The fix for this issue is included in the latest Toolset Blocks version 1.4.

Kindly update and verify the same.