Skip Navigation

[Resolved] Is There a Way to Disable Auto Indentation Correction?

This support ticket is created 3 years, 6 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 - -
13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 - -

Supporter timezone: America/New_York (GMT-04:00)

This topic contains 4 replies, has 2 voices.

Last updated by zacharyL 3 years, 5 months ago.

Assigned support staff: Christian Cox.

Author
Posts
#1305673

I initially tried reaching out via "Suggest a New Feature" but was told to submit a support ticket.

This video best illustrates my problem: hidden link

Basically, what's going on here, is that when I apply indentation for white spacing on my containers, the editor will automatically push the indented line back a few spaces, thus requiring me to tab it back in to my preferred indentation point.

I prefer to develop in a consecutive manner, moving from one element to the next, rather than skipping all over the place and adding things as I realize I need them. The auto-indentation forces me to stop moving forward, by forcing me to backtrack to correct the spacing. I'd rather not have to do this, if at all possible.

We've been working with Toolset for a couple years now, and this has been an ongoing annoyance of mine from the start. I've kinda just dealt with it, but lately I've just gotten tired of dealing with it. I get that it's just a couple more keystrokes, but if there is a way to disable this, assistance would be greatly appreciated.

The support representative that responded to my initial inquiry, Amit Kvint, stated this in his email:

"This seems to be coming from Codemirror. Codemirror would push indentation when it cannot understand the HTML. If you still have this issue please report in our support forum and one of our supporters can help you with this."

As this isn't specific to just one site, I haven't added access to the site on this post. If access is required, I'll be more than happy to supply it.

#1306027

Hi, I was just digging and found out something. Check out the Codemirror site here: https://codemirror.net/

At the top, you can see a demo of their code editor, outside of Toolset. The same indentation behavior can be seen here, so I don't think this is a bug in our software. It may be a setting in the Codemirror initialization scripts that can be adjusted, but right now there is no public API for doing that in Toolset. Check out the "Commands" section, there are several keyboard shortcuts for manipulating indentation on-the-fly. This approach is arguably a less disruptive experience than having to navigate back to the beginning of the line, and you can do it without manipulating editor configs.

Otherwise, I think the proper place for this suggestion is actually the feature request Form, because what you've described is the expected behavior of a Codemirror input field given the default settings. What you would need is a public API for manipulating those Toolset Codemirror settings in wp-admin, and that currently does not exist. I'll inform Amit of what I discovered and let him know I suggested a feature request.

#1306935

Ok, thank you very much for your assistance. Should I keep this support thread open in case there are any developments, or should I just keep an eye out for further emails from Amit?

#1307065

You can close out this ticket for now. The best source of upcoming feature release information is our blog, so I suggest following along: https://toolset.com/blog

#1310725

My issue is resolved now. Thank you!