[Resolved] "Invalid site key for the current site"

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 38 replies, has 32 voices, and was last updated by  fabrizioT-2 4 months ago. The support staff assigned to this topic is Luo Yang.

Viewing 15 posts - 1 through 15 (of 39 total)

Amit Kvint
Forum moderator

Hi everyone,

We have an open issue this morning with key registration on sites, our system team is working on it - if you see the error in the title this is probably caused by that temporary issue.

I will update here when we have a fix.

Sorry for that!


Amit Kvint
Forum moderator

OK, good news,

The issue is resolved - you can now go back to the page and register your sites with the correct key.

If you still have issues with this please comment here and I'll handle.

Sorry again!


We are having this issue with our websites. I can see an update for Toolset Views on multiple websites. All I have tried to update have said I need to register the site to receive updates.
Initially when I tried to log in to my account I was being redirected to wpml.org. I had to manually type in https://toolset.com/account to see a maintenance message.
Once the maintenance message cleared and I was able to login I attempted to reregister the sites with their existing key and received the "Invalid site key for the current site" error. I have also deleted and resubmit the site with the same error. This is both with http:// and https:// (sites are hidden link) as well as explicitly copying the URL supplied to me on the registration page in WordPress.

All websites are WordPress 4.9.1.


I just noticed that one of my sites is having this issue. The site is hidden link


Same here. My site at hidden link is giving the "Invalid site key for the current site" error, and it persists even after deleting the site key and recreating it.



Updates broken for me, too. With "Invalid site key for the current site." message.
Deleting key and generating new key not working either.


Broken for me too. I tried deleting the key and re-creating it and still no joy.


We have the same problem, when I enter the site key on the WordPress site, I get "Invalid site key for the current site." But if I try to register the site again on wp-types.com, it says the site is already registered.


I also have this problem.

Also tried deleting the key and generating a new one, but it didn't work.


same issue for me - After website stopped allowing updates to go through due to it reporting that the site wasn't registered (even though it's been registered since 2014) I tried deleting and re-adding a new site code with a message in wordpress of 'Invalid site key for the current site.' (copying and pasting the code)


I'm having this issue as well. Trying to update, but can't.


Also having this issue. I tried deleting the key and generating a new one, but it didn't work.


Same issue on at least one client site. Have yet to check others.


Having this issue now as well 12/12/2017.


I am Having the same issue

Viewing 15 posts - 1 through 15 (of 39 total)