Skip Navigation

[Resolved] Invalid Form Submission (nonce failure)

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Tagged: 

This topic contains 25 replies, has 13 voices.

Last updated by caseyJ 6 years, 5 months ago.

Assigned support staff: Waqas.

Author
Posts
#293432

I am trying to: test my CRED form that creates a new post

I visited this URL: hidden link

I expected to see: confirmation that the form worked

Instead, I got: Invalid Form Submission (nonce failure)

#293485

Follow-up - I think this may only happen when I'm logged into WP. I tried it while logged out and the form worked. Ideally I'd like to test it while logged in - is that possible?

#293487

@david-15: I can not begin to tell you how much your follow up saved me from another frustrated attempt to figure this out. I was having the exact same issue and couldn't figure out for the life of me what the problem was. Thank you so much. I look forward to a support response to this.

#293493

I'm also having this issue, thanks for reporting it.

#293498

To echo davidR-15's results.

I created a CPT with only the post title field. I disabled Access. I can submit the form when NOT logged in, but cannot submit the form as a subscriber or an Admin.

I can also confirm the results in his other thread as the Post Title is missing the first character.

Note: Reverting to the prior version of CRED (available in the changelog on the downloads page) resolves this error until a fix is available.

#293502

I also have have the same problem. Seems to be an error with the latest version of CRED.

#293695

Waqas
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I just tried this on my local host with CRED 1.3.6. I was logged in all the time and created several posts (standard and custom) but couldn't reproduce the issue.

However, I understand the severity of the issue since it's been reported by some clients today. I am following up with everyone accordingly.

For the time being, @davidr-15 can you please try disabling other plugins (except Toolset plugins) and see if problem persists. Also, try enabling each plugin one-by-one and keep checking for the issue. In case you succeed to pin-point the plugin having the issue.

If all above goes well, and problem persists in all cases, I will ask for a temporary access to your site. So I can investigate in more depth. I have enabled private details area for your next reply, please input all details. Also mention the CPT, CRED and Pages in question.

Please remember to take backup before providing the access.

For all other subscribers on this thread: Can you please open a separate thread to register this complain (if haven't open already)? So our supporters can ask for detail on each site separately. Unfortunately, on this thread only the thread creator can provide details for his/her site. Thank you for your understanding.

#293701

I deactivated all non-toolset plugins and tried aagain but I still get the same error message.

btw - I found another issue that I reported here: https://toolset.com/forums/topic/cred-is-not-saving-the-first-character-of-every-field-to-the-database/ - I think that one is a much bigger issue.

Happy to provide temporary access - however I don't see a private details area? Please advise.

Thanks for your help so far.

#293715

@waqas Bin Hasan - No problem!

#293913

I'm also having this issue today. Not sure if it's just coincidence but I updated Types today, and the site forms were working fine a few days ago.

#293920

Waqas
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Please accept my apologize in this regard, I am enabling the private details area again. Please input all details. Also mention the CPT, CRED and Pages in question.

Remember to take backup of your site before proceeding, thanks.

FYI: Your other thread is being reviewed by other supporter. And she will be in touch with you on that thread.

#293947

Waqas
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

In the meanwhile, I have reported the issue to the Dev Team. I will update you as soon as I hear back.

#294074

I am experiencing the same issue, I have create my own thread but it has gained any attention. Looking to get this resolved.

#294080

Hi, we have the same issue since we made an update last sunday!

#295043

same problem here.

we noticed it b/c on the front-end our forms are embedded in woocommerce views for products (w/Cred-commerce). clicking the 'submit' button does nothing on the front end - and returns 'nonce' when logged in.

quickfix: we removed Cred-1.3.6 & installed 1.3.5 - problem went away.

please let us know when this is resolved.