Skip Navigation

[Resolved] Infinite scroll does not show

This support ticket is created 6 years, 4 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 11 replies, has 2 voices.

Last updated by Ole Andreas Vekve 6 years, 4 months ago.

Assigned support staff: Luo Yang.

Author
Posts
#419855
Skjermbilde 2016-07-27 kl. 07.44.03.png

I am trying to: Add Infinite Scroll to my archive. However the icon does not show up. I have tried searching for the forum, but found nothing... Does not show in either Chrome or Safari.

I visited this URL: https://toolset.com/documentation/user-guides/infinite-scrolling-in-views/

Test URL: hidden link

#419890

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Dear Ole,

I assume we are talking about the spinners, I am trying to duplicate same problem, will feedback if there is anything found

#419894

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

The spinner icon only display when the browser need to load the next page, in your screenshot:
hidden link
the option "Pages to pre-load: " is setup as 4, so Views will load the pages 1~4 when user open the URL, if you need to display the spinner icon, please setup it as 1, see below test site:
hidden link
user/pass: xgren/111111

use wordpress archive:
hidden link

#419901

Thank you,

Yes. I have 8 posts. So it should have earlier.

But have set the pre-load to 1 right now. Also changed "Infinite scrolling tolerance" in pixels to 0.

#419938

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

242.JPG

I test again in your website, I can see the the spinner icon now, see bottom-right of screenshot 241.JPG, you will need to clear the cache of your browser, and test again.

#419947

Hi again,

That's wierd.

I have tried both Safari, Chrome and Firefox, on two different iMacs. None of them shows the spinner icon, even if I cache the browser.

#420214

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

I test again the problem URL, now I can not see the spinner, since I can not duplicate same problem, see above test site:
hidden link
user/pass: xgren/111111

use wordpress archive:
hidden link

Can you duplicate same problem in above test site, if you can not too, please check these in your own website:
1) Make sure you are using the latest version of Views plugin
2) deactivate other plugins and switch to wordpress default theme, and test again

#420236

Thanks,

Here is what I have tried:
- Deactivate all plugins except Types, Layout and Views,
- Remove almost all JS scripts in my header
- Changing to Toolset Starter Theme

None of these have worked. Meaning the problem should be in the Bootstrap loop. Or in the Archives.

I testet the Bootstrap in Archives, therefor I changed to Toolset Starter Theme. Trying different things, nothing worked.

I then went for the Archives, and there I found the problem.

It turns out the spinner does not load when "Pre-load the next and previous pages - avoids loading delays when users move between pages" is enabled.

Maybe you could check it out? I have updated your testing site so you can see it there.

#420241

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, checking it in the test site.

#420244

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks, I can duplicate same problem, and escalated this thread to our second tire supporters, currently you can disable the option "Pre-load the next and previous pages".

#421067

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Here is the feedback from our developers:
There will be no loading and the spinner will not be visible because the pages are already preloaded and the user will not have to wait for anything.

when pages are preloaded, there is no need to show a waiting spinner. I do nto think this needs to be documented either. Unless you want a spinner to be shown at all times, which is a valid point, I do not see any inconsistency.

This is also how other pagination efects (fade, slide) work. In those cases, even if you preload there is a chance you will see the spinners, because you can try to load page, say, 7, from page 1, and that page 7 might not be preloaded yet. On infinite scrolling, I agree that this can not happen, since page 1 can only lead to page 2 and not to page 7, but still if you scroll too fast you might be able to request a page that is not preloaded yet, hence the spinner will be needed.

#421151

Okay, that explains it.

Thank you,