[Resolved] imported toolset data did not invoke relationship migration routine

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by jimP 1 year, 9 months ago.

Assigned support staff: Minesh.

Author
Posts
#909602

I am trying to: transfer toolset relational CPT data to a new domain

Link to a page where the issue can be seen: hidden link

I expected to see: migrate tool to reestablish relationships given Types 3.0

Instead, I got: CPT relationships were apparently not recognized. All CPTs are there but no relationships between them.

I think the problem I summarize above happened because I transferred my Toolset data from a pre-3.0 Types site (Types 2.2.21) to a 3.0 Types site. At any rate, I'm giving you admin access below (though not yet sFTP access, which is a bit trickier) so you can help me diagnose/fix this major problem.

(Note that I did successfully migrate one site, with its own relational CPT data, to the new domain, but in this case I had not yet upgraded Toolset. Once I did so I was prompted to migrate relationships, and all basically worked out okay.)

#909818

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

Well - I see you are using Multisite install - what if you install Types plugin to your current site instead of network activate it and check if you can see the post relationship migration wizard. Does that helps?

#910715

Thank you for your quick reply. Unfortunately, network-deactivating Types (which I originally had network activated so that Toolset plugin updates would be automatically prompted...this is a multisite quirk I believe) then activating it on that site only did not change the situation; see attached screenshots showing both (a) all the intermediary CPTs that transferred over, and (b) the lack of prompt for migration assistant in Relationships window.

I'm happy to try other possibilities! Somehow we need Toolset to recognize the old relational CPT structure and prompt me to migrate it to the new relational structure.

Jim P.

#911155

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Well - I would like to still confirm - have you migrated to new post relationship before? if no: it should display the post relationship wizard.

I have created network install on my local and installed first Types version 2.3.1 and created many-to-may relationship and created few posts and connections.

Then, I updated the Types plugins to latest version 3.0 (network activated) and when I click on Toolset => Relationships , I can see that it offer me the migration wizard and once I run it - I can see relationship is successfully migrated and I can still see all content is connected as before. I do not see the issue somehow.

*** Please make a FULL BACKUP of your database and website.***
What if you try to run your backup again with legacy relationship and try to resolve your issue.

Please check following Doc - Section "How to Migrate" - and its works for me with network install.:
=> https://toolset.com/2018/05/when-if-to-migrate-relationships-in-old-toolset-sites/

Am I missing anything here?

#911208

To answer your question: yes, I have migrated from the old to new server successfully another site with similar relational CPTs, and was prompted to update relationships.

Here is the difference: in the case above, I had migrated from pre-3.0 Types to pre-3.0 Types, then updated Types, which prompted me re. relationships. In the current case, I have now updated Types on the new server to 3.0, so I am migrating from pre-3.0 Types on old server to 3.0 Types on new server.

This sounds a bit different from your trial, in that your post relationships are essentially migrated (in your case, created) *before* you update to Types 3.0.

You could say I should upgrade my old server to Types 3.0, update relationships there, then migrate; but I worry because we have many Toolset-based sites and some may break (e.g., with custom code, etc.). So, before taking this option I want to try and do what I summarize above: (a) migrate from pre-Types 3.0 server to Types 3.0 server, then (b) fix relationships.

Many thanks,

Jim P.

#911809

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Please do not forget - *** Please make a FULL BACKUP of your database and website.***

Ok fine - let me know once you successfully test your points (a & b) or I miss anything here.

#911861

I'm sorry, I think we are not understanding each other perfectly. When I say "I want to try and do..." I am gently requesting that you help me do what I want to do, so that I don't have to upgrade Toolset on my entire old multisite first, which may yield a number of failures on sites.

So, to say it another way, I would like you to give me a way to "… (a) migrate from pre-Types 3.0 server to Types 3.0 server, then (b) fix relationships."

Thank you for your support,

Jim P.

#912922

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

(a) migrate from pre-Types 3.0 server to Types 3.0 server, then (b) fix relationships.
=> Well - there is no manual way to fix relationshps as its automation process which is run by when you install the Types 3.0 plugin and when you navigate to the Toolset => Relationships.

I wonder why its not asking you the wizard to migrate the relationships when you once update your Types plugin to 3.0.

I would like to know after update Types plugin to 3.0 - what if you try to deactivate and reactivate the plugin again - does it makes any difference? If no:
The another way I can think of it what if you try to update and migrate the relationship before you change the server and then use Duplicator plugin to move your site - does that helps?

In any case - these are the critical steps to follow before you follow it:
*** Please make a FULL BACKUP of your database and website.***

#913042

Here is an update: (a) I deactivated/reactivated Types 3.0 plugin, and relationship migration wizard again was not invoked; and (b) I also upgraded to Types 3.01, and again the relationship migration wizard was not invoked.

I'm sorry, but your comment "The another way I can think of it what if you try to update and migrate the relationship before you change the server and then use Duplicator plugin to move your site - does that helps?" is exactly what I have mentioned I do *not* want to do, as this site is on a multisite and it may mess with many other sites that use Toolset. I will only take this option as a very last resort, as I'm sure it will create problems.

There is one more option for us to consider: I could build a single site with the old Toolset plugins, migrate my site to that one, then update the plugins, which should invoke the relationship migration routine. Then I could export from this second site and import to my new domain. In order to do this, please provide me links to download old versions of your Toolset plugins as follows (same as on my old server):

-Toolset Types 2.2.21
-Toolset Views 2.5.2
-Toolset Access 2.4.3.3
-[I don't believe my other Toolset plugins are relevant to this install]

Alternatively: can we please get another support person's opinion? Again, I want to find a way to invoke the relationship migration routine, possibly manually. The full thread of our conversation above should provide sufficient details, but I'm happy to provide additional details as needed.

Jim P.

#913135

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Well - if you will visit your Account's Downloads page:
=> https://toolset.com/account/downloads/

You will see list of plugins and with each plugin you will see the link "Changelog & Previous versions" just click on it and download your desired version.

Please try that and let me know how it goes.

#913548

Okay, I've now successfully migrated and updated relationships on a temporary single site, and am ready to export all this to my destination domain. Before I do so, one question (see attached screenshot): though my single view content templates look fine/unchanged, when I view a single CPT I get all sorts of the following unexecuted shortcode appearing here and there:

[hide-it]... [/hide-it]

What are these, and how may I remove them? I don't see them associated with any plugin I was using, nor can find this shortcode anywhere when I search.

Regards,

Jim P.

#913776

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Well - that shortcode should be added to your view or content template which you are displaying. You will find the shortcode when you edit your view or content template from where you should just remove it.

I do not know who write that shortcode and for what purpose it should be used. But you should for now just keep a note and remove it.

#913777

Okay, I found the solution: somewhere in the Toolset migration that shortcode was added to wpv-layout-start and wpv-layout-end, as you'll see in the attached....it's not in the content templates, which is what confused me. Not sure if others have experienced this as well.

Regards,

Jim P.

#914038

Okay, now a new question: as noted, I've successfully updated the Toolset Types plugin via an intermediary site, and confirmed all is good. Then I exported Types and Views structures via Toolset, as well as the site (Tools > Export). I then imported the structures, then imported the WP .xml file, and all imported **except for the relationships**. See attached for the relationships that were created on the intermediary site.

My question: how are you supposed to export/import CPT relationships with Types 3.0 and following? I assumed that they would be included in the Types export file as suggested here:

https://toolset.com/documentation/user-guides/exporting-and-importing-toolset-components-and-settings/

But then there is an entirely different process recommended here:

https://toolset.com/documentation/user-guides/importing-content-from-csv-with-post-relationships/

Which does not exactly clarify how one would export relationships prior to CSV-based import.

My CPT structure, content templates/views, and CPT content were all imported, but the relationships weren't, so that's my final step. (There were other minor irritations, e.g., content templates weren't applied to CPTs, but I can fix those.)

Thanks,

Jim P.

#914398

Another update: as of this AM, when I migrate to the dashboard of this new destination site, I get "There are associations ready for import." But when I then go to import those associations, I get only errors: "2876 Associations can't be imported" (see attached screenshot for first few).

Remember, this all has been migrated from an intermediary site in which everything was working fine.

I look forward to your update and guidance.

Jim P.