Skip Navigation

[Resolved] Image not displaying on the frontend

This support ticket is created 3 years, 2 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 - - 9:00 – 13:00
14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 - - 14:00 – 18:00

Supporter timezone: Africa/Casablanca (GMT+00:00)

This topic contains 2 replies, has 2 voices.

Last updated by laszloB 3 years, 2 months ago.

Assisted by: Jamal.


Dynamic Image Source not visible on the frontend page (see screenshots)
hidden link



Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+00:00)

Hello Laszlo,

I narrowed the issue down to the Monarch plugin. As soon as we deactivate it, the image appears. I also deactivated it temporarily on your website and the images appeared on the view.

So, I tried to reproduce the issue on a clean install but the issue was not reproduced. Maybe because I just installed the plugin without modifying any configuration on it.

If you need to continue using this plugin, would you please configure it on my test site similarly to your website and check if the issue will be reproducible? If it does, please let me know what configuration have you set.
You can log in to the test site with this URL hidden link
You can check the test page here hidden link

If the issue is reproducible there, I'll escalate it to our compatibility team. If it is not, we may need to further debug why is it happening only on your website.


I reviewed the Monarch settings only (I didn't change anything).
Deactivate then activate...
Miracle happened 🙂
I could never reproduce the error again.

My issue is resolved now. Thank you!

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.