Skip Navigation

[Resolved] I lost my layout

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by domenicoS 2 years, 6 months ago.

Assigned support staff: Beda.

Author
Posts
#1201230

Hi,

I worked on a layout. But there is now a problem.
When I open it I see only the blue bar anf no item are charged.

I see that the post associated to this layout are blank.

What heppens? How can I recover my data?

#1201239

I try to export layouts. But in the tour layout (where i have the problem) is not stored any data. Where are all data?? How can I recover it?
I can't replicate it..it was 2 months work

#1201259

With "Blue bar" you mean the AJAX progress bar that appears when you create or open a layout for editing?
If that is not going away, it means there is a JS error blocking the Layout from loading.
It should be visible on the Browser Console.

Most of the JS errors are due to compatibility issues with other software.
I suggest hence, to disable all plugins but Toolset and to use a native WordPress theme for testing if that solves the issue

If not, please zip up your site and send it to me, if possible.
https://toolset.com/faq/provide-supporters-copy-site/

If yes, then re-activate each plugin to find which is the culprit and report that to me.

Please also update all Toolset Plugins, WordPress and the Theme, before proceeding.
I suggest, making a backup before you do this update.

A backup would then help to go back if something goes wrong.

#1201264

Hi Beda, the problem is not a conflict.
All layouts works fine. The problem is only on the layout "tour".

Something heppenes yesterday when I worked on it.
I need only to find the backup file to recreate it.

Where I can find the tour-layout.ddl file via ftp?
I've a backup of it. If I find it I will replace the right data in a new layout.

#1201267

Toolset Layouts or any other Plugin does not create backups for you, this needs to be done manually.

For example, the Duplicator Plugin or similar can help with that.

You mention you a backup of it. That is strange, as Toolset Layouts offers no such features to backup a Layout.
It might be you mean an export?
In this case, you could simply re-import this layout.

Or, given that Layouts stores everything in the database (not the FTP) you could repopulate those values if they really are not in the database anymore, however that is unlikely.

I am sure there is a JS error in this layout, as the progress bar does not disappear, and once that is solved, this should be working again.
Maybe you added some custom JS to the layout?
Can you provide me with the data for deploying the site locally, so I can see what's wrong?
I need this anyway, in case I need to spot where and how to repopulate the layout in the database.

Thanks!

#1201268

Can I give you the access? I've not a duplicate of the website

#1201271

That does not help me, as I need to look into the database and that is dangerous per se (if I do something bad, everything is gone.)

Please follow the instructions on the link to create a duplicate:
https://toolset.com/faq/provide-supporters-copy-site/

What also works is a copy of the database and the FTP if your site is too large to duplicate with the above plugin or an All In one WP import/export.

Thank you!

#1202976
The requested URL /wp-admin was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

This is what I get after accepting the insecure HTTPS protocol used on the website (seems a self-signed certificate?)

Can you provide me with the proper access URL (maybe you customized it?)

I also downloaded the Duplicate, which features only the database.
I hence added a vanilla set of WordPress FTP Files (that is, WordPress and Theme Twenty Seventeen with Toolset, nothing else).
Using the wp-config.php file submitted I immediately got fatal PHP errors due to an overdeclaration of memory:

( ! ) Notice: Constant WP_MEMORY_LIMIT already defined in /Applications/MAMP/htdocs/duplicator/wp-config.php on line 71

I installed as well WooCommerce, but I could not install any of the other (many) plugins you use, as I do not have them/they are not made by us.

There is no Layout with ID 22340, in the database provided.
I could find an option, a user meta entry, and two entries in each a table wp_byt_accommodation_vacancies_days, wp_inbound_page_views, which are not tables added by Toolset (hence cannot hold the layout).

The Layout with lowest ID on your system is 22430, and that has no title, it's visible in hidden link

Do you mean that?
This layout is indeed used on WooCommerce Products, and I barely edit it, due to multiple PHP errors when editing it:

( ! ) Notice: Undefined property: stdClass::$Rows in /Applications/MAMP/htdocs/duplicator/wp-content/plugins/layouts/classes-auto/wpddl.layouts-cleaner.class.php on line 104
( ! ) Notice: Undefined index: width in /Applications/MAMP/htdocs/duplicator/wp-content/plugins/layouts/classes-auto/wpddl.json2layout.class.php on line 70
( ! ) Notice: Undefined index: cssframework in /Applications/MAMP/htdocs/duplicator/wp-content/plugins/layouts/classes-auto/wpddl.json2layout.class.php on line 70
( ! ) Notice: Undefined index: Rows in /Applications/MAMP/htdocs/duplicator/wp-content/plugins/layouts/classes-auto/wpddl.json2layout.class.php on line 84
( ! ) Notice: Undefined index: width in /Applications/MAMP/htdocs/duplicator/wp-content/plugins/layouts/classes-auto/wpddl.json2layout.class.php on line 70
( ! ) Notice: Undefined index: cssframework in /Applications/MAMP/htdocs/duplicator/wp-content/plugins/layouts/classes-auto/wpddl.json2layout.class.php on line 70
( ! ) Notice: Undefined index: Rows in /Applications/MAMP/htdocs/duplicator/wp-content/plugins/layouts/classes-auto/wpddl.json2layout.class.php on line 84
( ! ) Warning: Cannot modify header information - headers already sent by (output started at /Applications/MAMP/htdocs/duplicator/wp-content/plugins/layouts/classes-auto/wpddl.layouts-cleaner.class.php:104) in /Applications/MAMP/htdocs/duplicator/wp-admin/includes/misc.php on line 1144
( ! ) Warning: Cannot modify header information - headers already sent by (output started at /Applications/MAMP/htdocs/duplicator/wp-content/plugins/layouts/classes-auto/wpddl.layouts-cleaner.class.php:104) in /Applications/MAMP/htdocs/duplicator/wp-includes/option.php on line 919
( ! ) Warning: Cannot modify header information - headers already sent by (output started at /Applications/MAMP/htdocs/duplicator/wp-content/plugins/layouts/classes-auto/wpddl.layouts-cleaner.class.php:104) in /Applications/MAMP/htdocs/duplicator/wp-includes/option.php on line 920
( ! ) Notice: Undefined index: width in /Applications/MAMP/htdocs/duplicator/wp-content/plugins/layouts/classes-auto/wpddl.json2layout.class.php on line 70
( ! ) Notice: Undefined index: cssframework in /Applications/MAMP/htdocs/duplicator/wp-content/plugins/layouts/classes-auto/wpddl.json2layout.class.php on line 70
( ! ) Notice: Undefined index: Rows in /Applications/MAMP/htdocs/duplicator/wp-content/plugins/layouts/classes-auto/wpddl.json2layout.class.php on line 84

This does not seem to happen on other Layouts.
So my guess is the content of that Layout is breaking the site.

Assuming this is the right Layout 22430, I found that in the posts table of the Database.
It was last modified 2019-02-15 20:03:22
It has an empty post_content. There is not much I can do at this point as if the post content in the Database is empty for this post it means the Layout is empty.
There is no content in the Layout and I cannot recover it from this Database.
You'd need to have a backup from before, then I can apply that to the new Database and hope to fix it with.

I see that the errors above are all related to JSON decode, and it always is when getting the post content.
Checking post content on your site I see it's edited with a Builder, and that is not supported (if you use a Builder, like DIVI's, we do warn that you should not use Toolset Layouts: https://toolset.com/documentation/recommended-themes/toolset-divi-integration/)
It seems that here not only both builders got mixed, but it could be that some code added to the Post Content actually broke the update process of the Layout while you updated it, hence breaking it (Corrupting).

The best we can do here is to get a copy of before - a Database backup from before this happened, as I would not know how else to fi this, given the complete data of the layout is indeed gone (that would be the post content of the very layout saved in the database)

Do you have such backup?
Note, many times server hosts (where you store your site) do backup either with or without your knowledge.
Ask them if they have a database backup from before the issue happened. This could be our lifesaver here, unless you own such backup already, then I'd require it to copy out the post body and re-add it to the current layout.
That then would allow us to debug at least what happened and solve it on the site.

Right now, missing the content of the layout, I cannot even tell what to do to fix the issue since there is nothing we can "bring back" right now.

I am terrribly sorry this happened and would like to ensure you can at least restore the layout somehow.

#1213603

My issue is resolved now. Thank you!