[Resolved] I have two div inside the View loop that I don’t have added

This thread is resolved. Here is a description of the problem and solution.

Problem: I can see two extra div tags added in the markup generated by my View, surrounding the Loop Template:

<div class="et-l et-l--post">
<div class="et_builder_inner_content et_pb_gutters3">
[toolset content template]
</div>
</div>

Solution: Use the suppress_filters attribute in the Content Template shortcode:

[wpv-post-body view_template="your-loop-item-created-with-divi-template" suppress_filters="true"]

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by francescoG-3 5 months, 2 weeks ago.

Assigned support staff: Christian Cox.

Author
Posts
#1478257

I am trying to: Well, I'm using Divi with Toolset, I have created some CPTs, and relative View and Content Template and Relationship to display all relative posts and custom fields... And to now all worked fine...
So, after, I have needed to change two CPTs, than I have cloned the two CPTs, assigned to them the Custom Fields, the relative Views and Content Template and Relationship, and I have moved all posts from the old CPTs to the two new CPTs.
Now, only in the Views where are displayed the new CPTs posts have two div inside the View loop

<div class="et-l et-l--post">
<div class="et_builder_inner_content et_pb_gutters3">
[toolset content template]
</div>
</div>

So this two div create a problem to display the content in the correct mode on the pages because I have used the CSS Flex, and the two div brakes my design...

Link to a page where the issue can be seen:
hidden link on the homepage you can find the issue in the "Bandi e Avvisi" and "Comunicazioni" Sections.
hidden link In this page you can find the issue about the two div and also, now are not displayed the paginations on top and on the bottom of the posts section, and the paginations would be displayed (and before the change was displayed) because the View is set to display 10 posts per page, and the posts that would be displayed are up to 60...

I expected to see: something like this hidden link

Instead, I got: the issue

#1479705

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi, can you try adding the suppress_filters attribute to the Content Template shortcode in this View's Loop?

[wpv-post-body view_template="your-loop-item-created-with-divi-template" suppress_filters="true"]

What is the result?

#1479739

Hi Christian,
Thanks for your reply.

So, now adding the suppress_filters attribute, the two div are not displayed and then the Views are ok.

But here hidden link the pagination has not displayed on top and on the bottom of the posts section, and the paginations would be displayed (and before the change was displayed) because the View is set to display 10 posts per page, and the posts that would be displayed are up to 60...

#1481277

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Okay I will need to see how this View is set up in wp-admin. Can you provide login credentials in the private reply fields?

#1483159

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

To show the pagination elements, you must uncheck "Disable the wrapping Div around the View". I made this change and now I can see pagination appearing. Can you confirm?

#1483235

Ok, thank you!
Now I can see pagination appearing!!!

#1483237

My issue is resolved now. Thank you!