Skip Navigation

[Resolved] How to limit number displayed in slider

This support ticket is created 9 years, 8 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 8:00 – 17:00 8:00 – 17:00 8:00 – 17:00 8:00 – 17:00 8:00 – 17:00 -
- - - - - - -

Supporter timezone: America/Sao_Paulo (GMT-03:00)

This topic contains 12 replies, has 2 voices.

Last updated by Adriano 9 years, 8 months ago.

Assisted by: Adriano.


Hi. In older version when creating a slider view there was a section for Limit and offset where you could set the number of results returned. This no longer appears in the latest version, so could you please advise me how to limit the number of results to 5.

Thank you.


Dear Jill,

This option is still there on View edit page, see attached image.


Well unfortunately it does not show on my installations - see attached.

I have just installed two brand new copies of types and views on new domains using the installer.


Dear Jill,

Please let me know if you are satisfied with my answer and if I can help you with any other questions you might have.


Hi Adriano, I have entered details for access to a test site showing this problem.


Dear Jill,

That's strange, some kind of problem happened when this View has been built. I've just created a new one and the section is shown properly. I would recommend you to create a new one and delete that one, I don't understand what happened there, could you?


Hi Adriano. Well I can't understand it. I have just made a new view slider and it still does not show for me! Nor does it on another site! What on earth could I be doing wrong?

I click Views and then Add New View at the top of the page.
I get the pop-up window "Add a new View"
I select "Display the results as a slider"
I enter a name for the view and click create view

But for me the Limit and offset still do not show! I have tried it several times on both sites and it never works


I have now just tried it again but using a different browser (just in case!) but it still does not show! I usually use FireFox, tried Chrome


Hi Jill,

You are right. This functionality is not allowed for slider views. See attached image what is allowed when pagination is enabled. Otherwise you should create a default view, non slider view.


I don't understand, are you really saying that in the latest upgrade the option to limit the number of slides has been removed? That can't be correct. WHY remove such a thing?

I wish a slider to display only the latest 5 posts. I don't want it to go through hundreds of them! Are you really saying this is no longer available? It is no wonder that every time there is an upgrade it breaks my site.

In the test slide that you created on my site the limit and offset section is there. How come it shows there? What did you do?


Dear Jill,

Sorry my mistake. Limit and offset settings are hidden for sliders since 1.3, but they are available via the Screen Options at the top right of the edit screen.


PHEW! Well, we got there in the end! All is now well and I can once again see the Limit section!

Thank you


You are welcome.

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.