Skip Navigation

[Resolved] How to display full toolbar by default

This thread is resolved. Here is a description of the problem and solution.

Problem:
How to always show the Tiny MCE Toggle Editor bar

Solution:

function unhide_kitchensink( $args )
{
   $args['wordpress_adv_hidden'] = false;
   return $args;
}

add_filter( 'tiny_mce_before_init', 'unhide_kitchensink' );

Relevant Documentation:
http://wordpress.stackexchange.com/questions/52121/second-toolbar-in-tinymce-has-displaynone-set

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Tagged: 

This topic contains 4 replies, has 2 voices.

Last updated by Eric 5 years, 3 months ago.

Assigned support staff: Beda.

Author
Posts
#353978

On my CRED add and edit forms I'd like my users to see the full toolbar by default instead of having to click the "Toolbar Toggle" button. Is that possible?

#354247
Use Wizard or not.png
Tabs in CRED.png

Thank you for contacting us here in the Support Forum and for providing the Debug Informations

I'm not 100% sure but I think you mean why you see in my screenshot.

Those Tabs are always all opened by default, if you uncheck the Option "Create new forms using the CRED Wizard" in CRED > Settings

I also attached a screenshot of that settings screen.

If you instead use the Wizard, you will have a Step by Step CRED Form experience on New forms, while on edit form those will be still all presented as "open by default" tabs.

It might be that you closed those tabs, and then SAVED the CRED Form.

That will open the CRED also with closed tabs the next time.

If this is the case, just open all Tabs, save the Form and then re-call it, the Tabs should now all be open.

Please do not hesitate to open a new thread if other issues or problems arise

Thank you for your patience.

#354403
editor-views.png

Hmm. I think my original post wasn't clear. Sorry. I'm referring to the CRED form on the front-end that the user sees when adding/editing a post. I think my graphic will make sense.

Thanks,
Eric

#354675

I understand.

What you see is the Default WordPress TinyMCE Toolbar, and that always loads with the Hidden "Toogle" section.

It is the default and intended behavior of this Editor.

There are plugins you can use to modify this WordPress standard behavior, a example:
hidden link

Or you can use a Custom PHP Function like described here:
http://wordpress.stackexchange.com/questions/52121/second-toolbar-in-tinymce-has-displaynone-set

Please do not hesitate to open a new thread if other issues or problems arise

Thank you for your patience.

#356924

Thanks Beda. I went with the PHP function.
Happy new year!
Eric