Skip Navigation

[Resolved] How to create a template to display custom post filtered by tags?

This support ticket is created 6 years, 9 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 -
- 13:00 – 18:00 13:00 – 18:00 13:00 – 18:00 14:00 – 18:00 13:00 – 18:00 -

Supporter timezone: America/Jamaica (GMT-05:00)

This topic contains 4 replies, has 2 voices.

Last updated by Shane 6 years, 9 months ago.

Assisted by: Shane.

Author
Posts
#542597

Hi,

I've created a custom post "Doccuments"
I've created a view to display all documents hidden link

I am trying to:
All documents have tags. In the sidebar, I've added a widget to filter the documents (post) by tags.

I expected to see:
When I click on a tag, I'd like to show the filtered documents (post) in a similar custom template like "all documents"

Instead, I got:
The default masonry template of the theme that I use for the post hidden link

I don't know how to create this template to show the post filtered by tags.

Could you help please?
Thanks

#542701

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

Thank you for contacting support forum.

Actually it seems that the tags link to an archive so you will need to create a custom archive for this using our views plugin and then you can simply copy the design from your view and place it in the archive and it should be displayed similarly.

Please let me know if this if this helps.

Thanks,
Shane

#544319

Hi Shane,

Thanks. It helps but I still have a problem. It seems to be a css problem

I've created a WordPress archive view and applied the custom post type "documents"
Screenshot : hidden link

But I have a problem with the template because nothing is displayed on the page (filtered with the tag "Declaration")
hidden link

It seems to be a css problem because I see the result in the source <--wpv loop start--->

Could you have a look please?
Thanks

#544361

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Benoit,

Would you mind providing me with admin access to the website so that I can have a more detailed look at this ?

The private fields will be enabled for your next response.

Thanks,
Shane

#544432

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Benoit,

Could you temporarily disable all the non-toolset plugins and see if the problem still exists?

I'm checking right now and it seems that your footer and header area are not functioning well with a small content area.

Thanks,
Shane

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.