[Resolved] Guest users cannot see CRED form

This thread is resolved. Here is a description of the problem and solution.

Problem: The content of a page where a CRED form is inserted appears blank to guest users.

Solution: If you are using Access then you must set permissions for the CRED form to determine who apart from administrators can see and use the form.

Relevant Documentation: https://toolset.com/documentation/user-guides/access-control-for-cred-forms/

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 6 replies, has 3 voices.

Last updated by Nigel 7 months, 1 week ago.

Assigned support staff: Nigel.

Author
Posts
#608781

Hello,
When will this be fixed?
This is a real problem. User form not displaying for guest - patch did not fix!

#608788

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Hi Scott

I just tested this on a fresh install and it is working correctly with the current versions, guest users are able to see CRED User forms.

From your debug info it looks like you have the current versions installed, so I expect it is a problem with the settings.

When Access is active CRED forms are not visible to guests unless that is explicitly enabled.

Go to Toolset > Access Control > CRED Forms and make sure you enable access to the particular form for guests (see screenshot).

If you did already and it's still not working, let me know.

#608946

Hi Nigel,

thank you for your response.
I have the settings correct - see image.
Can you see this form?
hidden link
because I can't unless I'm logged in as admin.
I even tried check marking all levels and still nothing.
I also clear browser cache.

Thank you!

#608954

I can see the form if I'm logged in as Author, just to clarify. Havn't tested it being logged in as other roles. Not that that helps as they would already be users.
But as a guest I can't see it (I've tried both firefox and chrome)

#609174

Well....I just went to the form as guest and it magically appeared!!
Guess I'm good!!

Thanks!

#1394783

Hi I got the same problem, guests can't view the registration form.
But with my Administrator account and I can't modify no one of the checkbox in "User Form Front-end Access Group" and "Relationship Forms Front-end Access Group".
Looking at the administrator permission seems all checked..
How can we solve?
thank you

#1395113

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

@andrea if you are having problems clicking the checkboxes in the settings pages it sounds like you are using Access 2.8.1.2 which introduced this problem. Upgrading Access (current version 2.8.2) should fix this. Clear your browser cache if necessary after updating.

If you still have a problem, please open a new forum thread.