Skip Navigation

[Resolved] Guest access to page error. Oops, This Page Could Not Be Found!

This support ticket is created 6 years, 11 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 -
- 13:00 – 18:00 13:00 – 18:00 13:00 – 18:00 14:00 – 18:00 13:00 – 18:00 -

Supporter timezone: America/Jamaica (GMT-05:00)

This topic contains 5 replies, has 2 voices.

Last updated by leonardC 6 years, 11 months ago.

Assigned support staff: Shane.

Author
Posts
#450860

I am trying to: Give guests access to custom post content. I have set up all the Access permissions that I can find but still have one issue that I cannot resolve.

When a guest access a post through the following type of URL it works fine:
hidden link

But when a guest creates a post with the CRED form it cannot access the post through the following type of URL. This is the same post as in the example above but a different way of accessing it. It seems like this is the way the CRED form refers to the post after its created:
hidden link

The error I get in this case is:
Oops, This Page Could Not Be Found!

The post type is linked to a content template. Not sure if this is related to the problem.

#451017

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Leonard,

Thank you for contacting our support forum.

Would you mind providing me with admin access to the website so that I can have a look ?

The private fields will be enabled for your next response.

Thanks,
Shane

#451463

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Leonard,

I accessed the page using that url and it works fine after I changed the permalinks to the default one.

I'm not seeing anything wrong 🙁 I could be missing something.

Thanks,
Shane

#451477

Hi Shane

I just tested it again now and its still a problem. If I do a test now the URL works when I am logged in but not when I am not logged in.

Not sure what you mean by changing the permalinks?

Thanks
Leonard

#451487

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Leonard,

Whenever I try to access the page using this link hidden link as a guest it works i'm not getting a 404.

Thanks,
Shane

#451513

Hi Shane

Thanks, your response showed my what the problem is. When I create a new post with guest it does not show but the old one you tested worked. I found that the problem was that the form created the post in a pending state and this is what caused it not to be visible to guests but to other logged in users.

The one you tested was in a published state which made it work.

Thanks for the help with this.
Leonard