Skip Navigation

[Resolved] Google API REQUEST_DENIED – This API project is not authorized to use this API.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am seeing an error message in Toolset > Settings > Maps. It says "Google API REQUEST_DENIED - This API project is not authorized to use this API."

Solution: Check your settings in the Google API Console for this API key. Be sure that the Maps JavaScript, Places, Geolocation, and Geocode APIs are all enabled.

Relevant Documentation:
https://toolset.com/documentation/user-guides/display-on-google-maps/

This support ticket is created 4 years ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 6 replies, has 4 voices.

Last updated by rachelW-3 4 years ago.

Assigned support staff: Christian Cox.

Author
Posts
#954661

I am trying to: Display the Map

Link to a page where the issue can be seen: hidden link

I expected to see: The api has been verified

Instead, I got:This API project is not authorized to use this API.

I added a new unrestricted key today. It verfied just fine. Now I'm getting the authorization error. Errors like that led me to create the new key in the first place...

#954697
pic1.png
pic2.png

Hi, could you provide a couple of screenshots so I can review your API key settings? I need to see your Google APIs Console Dashboard (see pic1.png) and I also need to see the Credentials tab (see pic2.png). You can cover up part of the API Key for security. I'm deleting your image from the post, since these keys should not be public.

#954711
Credentials   WorcFoodandDrink.png
API Dashboard   WorcFoodandDrink.png

Ok here you go. For some reason I'm no longer seeing the apis the same way as in your screenshot. Here's what I do see.

#954719

Okay it looks like the APIs necessary to geocode addresses are not active for this key. Click the blue "Enable APIs and Services" button on the dashboard, and enable Places, Geocoding, and Geolocation APIs to start with. Then try to test the API again in Toolset > Settings > Maps tab. Let me know the results.

#955485

Thank you! It seems to work fine, now.

Perhaps the documentation on how to do this could be improved... if you can stay ahead of the changes at Google which is undoubtedly a challenge.

Thanks for your help.

#1171081

I agree with BrendanM4226, the documentation doesn't specify which API's are required to get full functionality.

#1236665

Agreed - this page here would greatly benefit by listing the three Google APIs you need to turn on for the plugin to work.

https://toolset.com/documentation/user-guides/display-on-google-maps/creating-a-google-maps-api-key