[Resolved] fusion builder not working with content template

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by Nigel 6 months, 4 weeks ago.

Assigned support staff: Nigel.

Author
Posts
#1333051

I am trying to: edit a content template with avada fusion builder

Link to a page where the issue can be seen:

I expected to see: fusion builder graphical interface

Instead, I got: text/code

#1333121

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Hi Malaga

By text/code do you mean you see the content wrapped in fusion builder shortcodes?

Something like in my screenshot?

Do you see the button to edit with Fusion Builder? Does it work?

Are there any errors showing in the browser console?

#1333133

Hi Nigel, yes, it's that type of code but no fusion button because it's already in the fusion editor. just that whether on visual or text tab - it's just the shortcode. see below. and errors seem unrelated. here the are:
Mixed Content: The page at 'hidden link' was loaded over HTTPS, but requested an insecure stylesheet 'hidden link'. This request has been blocked; the content must be served over HTTPS.
load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-ui-draggable,jquery-&load[]=ui-button,jquery-ui-position,jquery-ui-dialog,jquery-ui-tabs,suggest,underscore,shortcode,wp-util,wp-pointer,quicktags,wp-saniti&load[]=ze,wp-a11y,wplink,backbone,jquery-ui-slider,jquery-touch-punch,iris,wp-color-picker&ver=5.2.3:8 JQMIGRATE: Migrate is installed, version 1.4.1
post.php?post=57460&action=edit:1 Mixed Content: The page at 'hidden link' was loaded over HTTPS, but requested an insecure favicon 'hidden link'. This request has been blocked; the content must be served over HTTPS.
post.php?post=57460&action=edit:1 Mixed Content: The page at 'hidden link' was loaded over HTTPS, but requested an insecure favicon 'hidden link'. This request has been blocked; the content must be served over HTTPS.

[fusion_builder_container admin_label="med and large screen" hundred_percent="no" hundred_percent_height="no" hundred_percent_height_scroll="no" hundred_percent_height_center_content="yes" equal_height_columns="no" menu_anchor="" hide_on_mobile="medium-visibility,large-visibility" status="published" publish_date="" class="" id="" background_color="" background_image="" background_position="center center" background_repeat="no-repeat" fade="no" background_parallax="none" enable_mobile="no" parallax_speed="0.3" video_mp4="" video_webm="" video_ogv="" video_url="" video_aspect_ratio="16:9" video_loop="yes" video_mute="yes" video_preview_image="" border_size="" border_color="" border_style="solid" margin_top="" margin_bottom="" padding_top="" padding_right="" padding_bottom="" padding_left=""][fusion_builder_row][fusion_builder_column type="3_4" layout="3_4" spacing="" center_content="no" link="" target="_self" min_height="" hide_on_mobile="small-visibility,medium-visibility,large-visibility" class="" id="" background_color="" background_image="" background_position="left top" undefined="" background_repeat="no-repeat" hover_type="none" border_size="0" border_color="" border_style="solid" border_position="all" padding_top="" padding_right="48px" padding_bottom="" padding_left="" margin_top="" margin_bottom="" animation_type="" animation_direction="left" animation_speed="0.3" animation_offset="" last="no"][fusion_text hide_pop_tinymce=""]

[types field='chambermembers_description'][/types]

[/fusion_text][fusion_separator style_type="none" hide_

....etc....

#1333191

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

I think it would help if I could take a look to double-check where you mean, and to check the assets being loaded on that page.

Can I get access?

I will mark your next reply as private so that I can get log-in credentials from you—you may want to create a temporary admin user for me to use that you can later delete. And be sure to have a current backup of your site.

Which template are you editing?

#1334813

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Sorry, those credentials didn't work for me, could you try again?

#1334847

I edited private message with fixed password - sorry about that!

#1334891

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

OK, thanks.

The buttons for editing the template with Fusion Builder—or Gutenberg block editor—are entirely missing.

I don't see any related errors in the browser console, I'm going to take a copy to install locally to do some testing.

There may be something in your debug logs; I note while creating a duplicate that the debug.log file is 8Mb, so it seems there must be a lot of warnings and/or errors being generated.

I'll let you know when I've completed setting up the copy and have done some testing.

#1334893

thanks Nigel. sorry - i thought the button was missing becuase it was already being edited by fusion builder. because in toolset when you go to content template, there is a button that says 'edit with fusion'...

#1335015

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Got that. Because it's not working it wasn't clear you had.

I can confirm that the Avada UI isn't loading when editing content templates on your site, whether editing an existing template or whether you create a new template and try to edit it with fusion builder.

I can't reproduce on my own Avada test site, though. I'm guessing this occurred after the recent Avada 6 update.

In any case, I've made a slimmed down version of your site and passed it to my colleagues for deeper debugging.

I'll keep you posted.

#1335017

thanks. after the last updates of wp and toolset, the code i have in there with flexslider stopped working. that's the real problem. was trying to see the page in fusion to try to troubleshoot that.

#1337249

Hi, is there any update? this is a business critical issue. Thank you!

#1337331

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Hi Malaga

My colleague is still working on this, he's identified some problems but has determined why they are happening, although they are only affecting your site, we haven't been able to reproduce them.

As a workaround you can add this function to your theme's functions.php file:

/**
 * Workaround for editing CTs with Fusion Builder
 */
add_filter( 'fusion_builder_allowed_post_types', 'support_medium_custom_alt' );
function support_medium_custom_alt( $allowed_types ) {
		if ( ! in_array( 'view-template', $allowed_types ) ) {
			$allowed_types[] = 'view-template';
		}

		return $allowed_types;
}

Then in the backend go to Fusion Builder > Settings and save the page (you shouldn't need to make any changes).

You should then find that you can edit Content Templates with Fusion Builder again.

If you can't identify what's wrong with your flexslider, give me some more details and I'll take a look.

If you have any information to share about when this stopped working and what you had done prior to that (e.g. upgrades) that would be helpful.

#1337333

Thank you Nigel, I had found that fix (or something similar) but it didn't work - but I'll try again. Can you tell me where in the functions file this should be placed? does it matter?

#1337349

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Doesn't matter where, just pop it at the end of the file.

#1337353

ok. that's what i did but maybe your code is different. will try. thanks.