Skip Navigation

[Resolved] Frontend editing Jetpack conflict

This support ticket is created 6 years, 6 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- - 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00
- - - - - - -

Supporter timezone: Asia/Ho_Chi_Minh (GMT+07:00)

This topic contains 5 replies, has 2 voices.

Last updated by morktron 6 years, 6 months ago.

Assisted by: Beda.

Screen Shot 2017-05-27 at 11.41.23 am.png

I am trying to: Have the Jetpack plugin enabled

I visited this URL: Frontent edit cpt url

I expected to see: The edited cpt url

Instead, I got: "There was an error whilst submitting the form"

When Jetpack is enabled frontend form submission works but remains on the edit page and returns an error. If Jetpack is enabled but not connected to there is no error.

I'm using the Divi theme. It would be great if Jetpack could be enabled without Toolset breaking. I suppose I should switch a default theme but then I'd lose all my settings...


I am not sure what steps I need to follow.

I activated the Jetpack and CRED, and inserted an edit form to a Post.

This works perfectly fine.

What are the steps to replicate the issue?

Screen Shot 2017-05-29 at 9.36.05 am.png
Screen Shot 2017-05-29 at 9.35.21 am.png

Thanks for getting back to me Beda, I switched to the 2016 theme and disabled all plugins except for the Toolset ones and Jetpack.

The issue is still there. However, you won't see the issue unless you connect Jetpack to a account.

I can give you my admin details if you want?


This is not replicable

I tested it with the free package of Jetpack and a CRED Edit Form, which should show the post after editing it.
This works just fine.

This must be a very specific issue.

At first, I will look into your site, but I cannot promise a fix.
Then, if I cannot fix it, we will require a Test Server (this is free of charge) and you can deploy your site on that Server, to which I will have full access.
We can then check if it's a server issue or not.

Also, could you please give me the exact Error that happens?
Thing is, "There was an error whilst submitting the form" is not a CRED error message.
It doesn't exist in the code base.

Also, a look at the console and WP Debug could tell us more right away:

I enable a private reply in case after all this the issue is still happening and unclear.


No, that Bug is not solved:

aheckler commented on 1 Feb
@rajchappeta Yep, as long as you have one published post, this error can be avoided. It'll be fixed altogether in the next Jetpack release.

hidden link

This means it is still there and will be fixed in the "next release".
Not sure when that is or was but it has not been resolved yet.

The BUG is not related to Toolset.

But, I see now you use AJAX in the CRED form.

And that is the issue.
Remove the AJAX Submission and the redirect delay of 6 seconds (I've done that already on your site) and things start to work.

So, I will re-iterate a set of tests using AJAX in CRED Forms, to see if that is an issue.

Please can you confirm meanwhile that the above edits solved the issue for you too?


Ok thanks Beda, I see it works with Ajax disabled as you said. So I will disable Ajax for all frontend forms and hope that Jetpack fixes the bug one day so we can use Ajax with Toolset.

Publishing a post as a temporary workaround didn't fix the issue for me.

Thanks again for your help

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.