Skip Navigation

[Resolved] Framework installer erased WordPress DB

This support ticket is created 3 years, 6 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Shane 3 years, 6 months ago.

Assigned support staff: Shane.

Author
Posts
#1221544

I try to Install Classified with Framework Installer. After I click Install Classified Framework Installer try to import demo data and erased all tables within WordPress Database but try to nothing import. Please help!

#1221553
Warnings.png

This is clearly stated before you import any site.
It will delete your database (overwrite it)
It does not do this without the clear agreement of the user (hence, just activating the plugin will not delete the database)
Only after you clearly agreed, you can proceed with the processes:

 I understand that all my data will be erased from this website.

 I have a backup of my database and all my files.

There is not much we can do after the database is overwritten.
You can try to ask your Server Host if they keep backups of it.
That can help to re-install your previous database.

Now if this is about the missing import, it is very crucial that you have an outstanding Internet Connection to import that site.
Please proceed as follows:
- open the browser console > network
- run the import
- observe if the network reports little bulks of data being loaded, ca 500mb each bulk
- do not close the browser or interrupt the internet connection during this process
- it may require a few minutes (up to half an hour)

#1221617
Screenshot_2019-03-27 Wählen Sie eine Referenzseite zur Installation aus ‹ UVDR — WordPress.png
Screenshot_2019-03-27 kugellagermarkt de 8443 localhost wp_k7er0 phpMyAdmin 4 8 4.png

Hello Beda, thanks for your reply. The problem is that nothing imports since all data was erased.

#1221744

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

That is strange, it should write the data to the database after the import.

Could you try importing a different demo site and see if it imports?

If not please let me know.

Thanks,
Shane

#1222338

Hello Shane,

with Membership Layouts is the same problem. DB was erased, checked green as success and nothing in DB.

Thanks!

#1222460

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

Seems like an issue where the site is unable to write to the Database.

I just tested this to ensure it's not an issue on our end and it works fine. Would you mind allowing me to have access to the site to check on this for you ?

Thanks,
Shane

#1223073

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

I see the issue. The problem is that the installer isn't allowed to run to completion. It seems that it's being interrupted. Could you reset the site once more since it is a fresh site so that I can check the debug data for the site.

Thanks,
Shane

#1223079

Sure, i have made Site Reset for you. You can now debug the data.

#1223177

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

Your debug information checks out fine.

Are you able to access the server logs ? This could point to the issue. If youre able to access the server logs please let me know if not then I can export the demo that you want and import it manually to your site.

Please let me know.
Thanks,
Shane

#1223770

Hello Shane,

which collaction you used for import data? I have found that after DB Error Collation FastCGI sent in stderr: "PHP message: WordPress-Datenbank-Fehler Unknown collation: 'utf8mb4_unicode_520_ci'
Should I set utf8mb4_unicode_520_ci Collation for my DB?

But i can't found utf8mb4_unicode_520_ci collaction under my DB Options.... I have utf8mb4_unicode_ci collation without "520".

#1223944

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

Could you check what version of MySQL you are using ?

Could you let me know if it at least version 5.6 ? If not then you can upgrade to this version. The other alternative is for me to provide a backup file with the site import that you want with the collation changed.

Thanks,
Shane

#1223977

I have MySQL 5.5.62
Upgrade is not the options for me. I have many live projects on the server. it can break my sites.
So please send me your backup files.

#1224015

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

This is a backup done with the All in one Migration plugin.
hidden link

You will need to install the All in One migration plugin install the backup.

Please let me know if this helps.

Thanks,
Shane