Skip Navigation

[Closed] Forms 2.5.5 breaks WP Admin

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 13 replies, has 3 voices.

Last updated by Christian Cox 5 months, 2 weeks ago.

Assigned support staff: Christian Cox.

Author
Posts
#1521451

When upgrading to Forms 2.5.5 today, access to wp-admin was lost. Deactivating the plugin makes wp-admin work again. The error that occurs is shown here:

Uncaught Error: Call to undefined method ToolsetCommonEs\Rest\API::apply_script_data() in /www/wp-content/plugins/cred-frontend-editor/vendor/toolset/common-es/php/bootstrap.php on line 101
{closure}()wp-includes/class-wp-hook.php:288
apply_filters()wp-includes/class-wp-hook.php:312
do_action()wp-includes/plugin.php:478
do_action()wp-settings.php:526
require_once()wp-config.php:89
require_once()wp-load.php:37
require_once()wp-admin/admin.php:34
require_once()wp-admin/plugins.php:10
There has been a critical error on your website. Please check your site admin email inbox for instructions.
#1522321

Can you deactivate all Toolset Plugins, then head to the Plugins > any toolset plugins > registered (commercial Plugins tab) and check for updates
Update to the versions offered and repeat that process until "check for updates" does not show any more available updates

It might be that you need to update twice or more times for some plugins.

The last versions available can be seen here https://toolset.com/account/downloads/
You are still using some older versions which conflict with each other.

After updating all those Plugins, reactivate them one by one, this should resolve this issue

#1522357

Thanks for getting back to me.

I will try this, but:
1. This is a live and very large site. So doing it on a staging environment is difficult.
2. Why does Toolset keep breaking sites? It seems to be getting worse!
3. Even if this does work, this is an unsatisfactory way for a premium plugin to work. Don't you agree?

Best wishes,
Andrew.

#1522449

Thank you for the feedback.

Please let me know if I can help with further technical problems, or if any issues persist after the updates.

For issues with the software or complaints that (such I can't solve here), I suggest you contact the Product Management and Support Supervisors here https://toolset.com/need-help-toolset/

Thanks!

#1522467

Yes, you can help with further technical problems. Because the technical problems have not been resolved!

#1522475

Do you mean, you have followed the steps here https://toolset.com/forums/topic/forms-2-5-5-breaks-wp-admin/#post-1522321 and still see the same error?
This is unusual, it should not report any error, as I confirmed as well on several sites with the latest Toolset

Can I gain access to the system, and ask for permission to manually delete the Toolset Plugins and upload a fresh set of them?

#1522501

As I mentioned, this is a live site, and important live site. We can't be removing these plugins with no guaranteed outcome.

And making a staging copy will take ages. It's a huge site of around 9GB.

Is this really the future of using Toolset, every time there's an update? we have to go through all of this?

#1522507

I've re-enabled the private reply, as this is deactivated each time a reply is submitted and not used.

Please let me know once the access to the staging site is ready.
I will be around ca. one more hour and then back on Tuesday.

On weekends the support is maintained by me on Saturday and Christian on Sunday only.
Please let me know if you want me to forward the tickets to next supporters.

#1522513

So in an hour, I get no more support until Sunday at best? When your plugins are breaking my websites?!?!?!

Have you not taken note of the fact that your plugins are breaking my sites, and therefore this is an emergency??? You can't just wash your hands of it like that.

And...again...it will take hours to create a staging site. It's huge? Why is any of this necessary? You've still not explained what is so wrong with your plugins that they can't be updated in the same way as any other WordPress plugin without breaking websites?

What is the problem?

#1522543

I apologise that this is how the support here works, I cannot stay overtime.
On weekends the support is limited.

If you would have submitted me with some access details I could take a look right now, as my shift is about to end, but I have no access details to resolve this problem with a manual upload of the latest plugins.

Note that this is a compatibility issue, most likely, in case it still happens after the correct updates since I cannot see this error anywhere else.
On a staging site, we could then control this deeper if the updates will not solve this issue.

I have now re-enabled the private reply for you to add access to whichever site you would like to analyse this first, and unassigned the ticket from me, so tomorrow Christian can pick it up or Monday someone else, as I am on my Weekend until Tuesday.

I apologise that this delays on weekends. I can recommend having a staging site ready at all times for such updates and other things to avoid conflicts like these in future

#1522549

I do have a staging site ready at all times, it currently holds the new design of the website which will be going live next month so can't be over-written.

The issue here is not how I manage my staging site. The issue is why toolset KEEPS BREAKING WEBSITES and why you are unable to help when your plugin breaks websites, and you wash your hands with responses that go round in circles and do not help at all!!!

I need support TODAY to fix the mess that Toolset plugins have made of my sites?

#1522555

OK, then we can try to see what is wrong on that staging site

Please use the private reply to add the login details so Christian can look at this tomorrow.

#1522557

No, you cannot "try to see what is wrong on that staging site" because it is an important site featuring months of work and I cannot afford to have that ruined as well!!!

#1523867

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hello, if you'd prefer that we did not work on your staging site, I'll be glad to work with a clone of your site. I can install that on my local environment and do all the troubleshooting here without further impacting any of your live environments. I can work with a Duplicator clone package, or a package from All-in-One WP Migration. If you want to create either of those and provide a download link for me here, I'll be glad to take a look. Or if you would prefer I make the clone myself, I need login credentials. Let me know how you would like to proceed.

The topic ‘[Closed] Forms 2.5.5 breaks WP Admin’ is closed to new replies.