Skip Navigation

[Resolved] flexslider help for a gallery with multiple custom fields form one post

This thread is resolved. Here is a description of the problem and solution.

Problem:

The issue here is that the user had some repeated image fields and wanted to create a slider using these images.

Solution:

I managed to create a flexslider plugin that should be able to help your.

Download and install the plugin in the link below.
https://drive.google.com/file/d/1CFU2_oBqe9PJBks8cT1VqMND8-ytDdVE/view?usp=sharing

Then create a content template for your post and add the following.

<div class="flexslider">
  <ul class="slides">
   [wpv-for-each field="wpcf-image_1"]
  <li>[types field="image_1" size="medium" align="none" resize="pad" padding_color="#FFF"][/types]</li>
  [/wpv-for-each]
  </ul>
</div>

After doing this then you will need to add the script for it to work.

Add this to the js section of the content template.

jQuery(window).load(function() {
   jQuery('.flexslider').flexslider();
 });

100% of people find this useful.

This support ticket is created 5 years, 1 month ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 -
- 13:00 – 18:00 13:00 – 18:00 13:00 – 18:00 14:00 – 18:00 13:00 – 18:00 -

Supporter timezone: America/Jamaica (GMT-05:00)

This topic contains 16 replies, has 2 voices.

Last updated by Anonymous 5 years, 1 month ago.

Assisted by: Shane.

Author
Posts
#1205802

Anonymous

Hi Shane, you helped me earlier. I tried your info about flexslider and couldn't get it to work. Would you have a moment to help me? please ?

Tell us what you are trying to do?
flexslider help for a gallery with multiple custom fields from one post, using this help page : https://toolset.com/forums/topic/generate-slide-on-my-slider/.

Thanks.

#1205805

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

The link actually still works.

I just checked on my end. However could you let me know what you are seeing?

Please send a screenshot.

Thanks,
Shane

#1205806

Anonymous

Yes, I tried «log-in» and it worked. So I went to the coding part and I don't quite understand I guess. It doesn't work for now. Do you mind helping me a bit?

#1205807

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

Yes sure, I lost the chat ticket could you resend the credentials here as well as the page where you are setting up the slider?

Thanks,
Shane

#1205809

Anonymous

Do you mind helping me with this?

#1205810

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

Its saying the password is incorrect.

Could you try on your end and let me know the results?

Thanks,
Shane

#1205814

Anonymous

Oh really sorry! Try again, please. It should be OK by now. (It works) Thank you, Shane.

#1205829

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

I resolved this.

It seems you were using a repeatable field group which means it took a little bit more work to adapt the code to the content you have.

Here is the view that I used.
hidden link

Then I just added it to the Layout.

Please let me know if this helps.
Thanks,
Shane

#1205835

Anonymous

It sure helps! The «only» thing missing is the caption, alt or title or the "legend" - the reason forthe repeatable field group. They are both the same. Would you know to add the (or some) text to the slider? I really appreciate your help, Shane. Thank you! I spent many hours trying before writing for help, so thank you !!!

#1205842

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

Take a look here.
hidden link

What you need to do is modify the view that was created and add the tag
      <p class="flex-caption">Adventurer Cheesecake Brownie</p>

Where it should be based on the example.

Thanks,
Shane

#1205844

Anonymous

OK, I will try later on tonight. Thank you again Shane. Very much appreciate. 🙂

#1206345

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

I'll mark this one as resolved.

Thanks,
Shane

#1207761

Anonymous

Hi Shane, it is me again... I'm sorry to bother you again, but when I close your temporary account, I mistakenly erased the gallery you helped me with. :[ I tried again this morning with the same kind of misunderstanding. I did not had the chance to understand what you did... Would you mind helping me again please?

#1207767

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

Sure please open a new ticket and assign it to me.

Also please provide the credentials to the site as well 🙂

Thanks,
Shane

#1207768

Anonymous

I am SO sorry... I did not think about the gallery when I closed it. Well, you are very kind to help me again!

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.