[Resolved] Featured Image not displaying in view

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Christian Cox 3 weeks, 1 day ago.

Assigned support staff: Christian Cox.

Author
Posts
#1387293

I have a view setup to show an image preview of the featured image in the News post. It should display a cropped version of the image in a grid. This works for images that are square but not with 16x9 for some reason.

It can be seen here:
hidden link
Under "Latest News"

Here is code in the view:

<div class= "news-title">[title][wpv-post-link][/title]</div><br>
<td><a href="[wpv-post-url]">[wpv-post-featured-image size="custom"  width="768" height="432" crop="true"]</a></td>
<br><br>[wpv-post-excerpt length="85"]

The image not showing is actual 1200x675 so bigger than the crop.

#1387341

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Hi, I don't see anything obviously wrong with this code. Similar code copied into my own local site seems to work as expected, so I'm not sure what's going on here. If I inspect the site, I can see that the image tag is written out, but the image is missing (404) from the server: hidden link

I'm not sure why that would be happening. Can you try the following troubleshooting steps?
- Try uploading a new image to the Media Library. Is this image stored successfully, or do you see any error messages in wp-admin?
- Go to wp-admin > Settings > Permalinks and resave your site permalinks.
- Be sure your Toolset plugins and WordPress installation are up-to-date.
- Temporarily deactivate all plugins except Types and Views, activate a default theme like Twenty Nineteen, then place the View with the missing image directly on some test Page.
- Check the test Page on the front-end of the site.
- If the problem is resolved, reactivate your theme and other plugins one by one until the problem returns.
- If the problem is not resolved, I'll need to take a closer look.

Please let me know what you find out and we can go from there.

#1387345

Hi,

I tried those things, no change. It is weird, if I put a square 1200x1200 image in it works. But, anything like the 1200x675 does not work, have tried a couple different ones.

#1387363

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Okay, that's strange. Can you upload your site's debug information here in the debug fields for me to review? You can find instructions in this article: https://toolset.com/faq/provide-debug-information-faster-support/

Please create a phpinfo page as well (see the "How to check the PHP version" section for more info about this: https://toolset.com/toolset-requirements/) and let me know where I can find it on your site. I'll review your PHP configs and see if anything unusual sticks out.

#1387561

So it randomly started working. Weird, I did not do anything. I have included the debug info in case you wanna take a peak. I am using PHP 7.3.

Thanks

#1387987

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I don't see anything obviously wrong in the debug information you provided, so I'm not really sure what's going on here. If you experience the problem again with another image, feel free to reopen this ticket or start a new ticket. We can activate server logs and see if there is anything noteworthy logged by the server.