Skip Navigation

[Resolved] Fatal error – View on woocommerce products.

This support ticket is created 9 years, 10 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 8:00 – 17:00 8:00 – 17:00 8:00 – 17:00 8:00 – 17:00 8:00 – 17:00 -
- - - - - - -

Supporter timezone: America/Sao_Paulo (GMT-03:00)

Tagged: 

This topic contains 4 replies, has 2 voices.

Last updated by Adriano 9 years, 10 months ago.

Assigned support staff: Adriano.

Author
Posts
#65407

I'm running the latest version of types & views and woocommerce. I have a few hundred products that I have imported using the WooCommerce Product CSV Import Suite. I can display my products no problem using the woo shortcodes.

Any views I create on products just give me an out of memory error:-

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 64 bytes) in /home/wpstage/public_html/mysite/wp-includes/meta.php on line 571

I've enabled all logging and get no messages reported except for the above.

I've simplified my view to just display post titles - and I've tried reducing the result to just the first record - but the error persists in all cases.

#65572

Dear Simon,

Did try to increase the allocate memory?

#65578

Well - it's already double the base setting, at 64Mb - the view should be returning 300 view titles (or just one) - nothing else, aside from the toolset and Woocommerce there is nothing installed on the site - Do you really think it could be the memory?

Last time I had a similar problem it had nothing to do with memory. What would you suggest I increase it to, for Types & Views to run successfully?

I have added the toolset to the Woocommerce site from which I did the original export, and there it runs no problem (I'm not aware that the site owner has increase the base memory, but I will check).

#65909

Hey Adriano,
First, apologies for my blast of an answer - my sarcasm wasn't appropriate.

Yes - it is just a memory problem this time!! I've increased memory to 128Mb and the query now runs fine. I guess I've got used to it not being the case.

Apologies again and thanks for your help.

#66002

Great, you are welcome.