Skip Navigation

[Resolved] Extra code getting appeneded in custom taxononmy name field

This support ticket is created 9 years, 5 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 19:00 10:00 – 19:00 10:00 – 19:00 10:00 – 19:00 10:00 – 19:00 -
- - - - - - -

Supporter timezone: Europe/Madrid (GMT+01:00)

This topic contains 4 replies, has 2 voices.

Last updated by Alok Sharma 9 years, 5 months ago.

Assigned support staff: Caridad.



I created a custom taxonomy viz Email and entered a email address. But when I came back to modify the slug, I saw the following code appended in the Name field of the Email taxonomy but slug remains the same.* <![CDATA[ */(function(){try{var s,a,i,j,r,c,l,b=document.getElementsByTagName("script");l=b[b.length-1].previousSibling;a=l.getAttribute('data-cfemail');if(a){s='';r=parseInt(a.substr(0,2),16);for(j=2;a.length-j;j+=2){c=parseInt(a.substr(j,2),16)^r;s+=String.fromCharCode(c);}s=document.createTextNode(s);l.parentNode.replaceChild(s,l);}}catch(e){}})();/* ]]> */

Any clues what could be wrong and from where this code is getting appended.




Update: Today I found something new. If I separate @ with space (for e.g. some-email-address @, that strange code does not gets appended. However, for the existing taxonomies, I had to edit them and remove the code that was already appended.


Dear Alok,

You must have another plugin installed trying to protect your email address from spam bots. Is this the case?




I tried deactivating all the plugins but still the same thing. I then tried this in my localhost installation with default WP theme and wasn't able to replicate this problem.

Looks like this has something to do with iFeature Pro theme. I will try if I can get some support from there.




Update: I was finally able to figure this out. This appears to be happening out of CloudFlare's E-mail address obfuscation feature.