Skip Navigation

[Resolved] Error in Classifieds-Demo Views Template for Get Currency Symbol and Layout

This support ticket is created 7 years, 5 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by PatL 7 years, 4 months ago.

Assigned support staff: Beda.

Author
Posts
#300639

Hi,

I've been working with the Classifieds Demo and using the examples to create new CPT's, Views, Content Templates etc. I've just been copying the code from the original 'Listings' CPT and it's related Views etc, but somehow, i've managed to 'break' the homepage and most of the pages that are pulling data from this Listings CPT.

Please can you help me take a quick look to see what has gone wrong. It's very strange, as i have another copy of the Classifieds Demo (which is working perfectly) installed on a separate domain, and even when i copy the exact same code over, one works but the other doesn't.

1) Homepage (you can get the domain from the debug information i submitted)

- The currency symbol is not showing. Instead of "USD 1998" it is showing "1998[classifieds-currency get=??currency_symbol??] [classifieds-currency]"
- The (horizontal) layout of the 'Featured Listings' is also messed up

2) Listing Page (hidden link) has totally disappeared.

3) Ads List Page (hidden link)

- The currency symbol is not showing. Instead of "USD 1998" it is showing "1998[classifieds-currency get=??currency_symbol??] [classifieds-currency]"
- The horizontal layout for "Edit, Delete etc" has messed up.

I've spent almost 2 hours trying to solve this but can't see what's wrong. Would really appreciate some help. It must be something really simple, as i haven't done much to the site.

Please enable the login info submission section and i'll share the details.

Thanks

#300852

Thank you for contacting us here in the Support Forum
and for providing the Debug Informations

It seems you missed some HTML markups when copy and paste your View's Content
(that would at least explain the messed up layout on the homepage)

The issue with the Currency Symbol not rendering, but instead the whole short code, I could not reproduce, but it seems some "typo" in the short code as well.

To debug this, I need access to the site.
I would need to request temporary access (WP-Admin and FTP) to your site
- preferably to a test site where the problem has been replicated if possible -
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private which means only you and I have access to it.

?? Please backup your database and website ??

✙ I would additionally need your permission to de- and re-activate Plugins and the Theme, and to change configurations on the site.
This is also a reason the backup is really important

Regarding the missing Listing "Beach House", please can you try to re-save the Listing from the Backend
Dashboard > Listings > Beach House and check if that brings it back on the front end?

Please could you provide me the additional Infos,
and as well permit me to perform the required steps?

Thank you

#301133

Thanks for the Details

I have tried to locate the issue, but could not find it.

Replacing the Views and Content templates or Post Contents (mockups) from a clean install of the Classifieds Site did not bring the desired solution.

I have put your and mine HTML output in a DIFF checker and all differences I could find where from Jetpack, which I don't have installed, and WooCommerce, which seems to overwrite some HTML in your site.

I have installed WooCommerce too, but on my end the HTML Output comes from Bootstrap, while on your site it is overwritten by WooCommerce, looking at the single Ads.

Checking your Views preferences for templates in Views > Settings, we have the same settings, therefore the issue can't be generated by this.

I also checked this page: hidden link
This content is actually available but under a different URL:
hidden link

So what happened here is that you have already added Location to that Post, and you also have a quiet different Permalink Structure then the "default" one, looking at
Dashboard > Settings > Permalinks, section "Permalink Setting for custom post type"

This section seems to be added by a 3rd Party Plugin, as it is not part of our Plugins.
Therefore it is probably expected that you have a different Permalink structure.

Now, for the main issue about the "messed" up layout and the short codes not properly generating HTML:

I note a few differences from mine to your install:

1. You miss the Module Manager Plugin, which is required for Framework Installer
2. Your plugins need to be updated
3. You use different 3rd Party Plugins then I do

Even if no of the above point seems directly related to the issue, I would like to ask you if you have the chance to "start" over with the Toolset Classifieds Example site.

Try this with the minimal necessary plugins only, and with the "as is" settings when you freshly reset or install the Demo site.

If you don't have much customized content yet, this is the fastest and most secure way to have a clean install to work on.

Please make sure to utilize updated plugins on a clean Install.

Please let me know if you already have to much content to start over and would like to have me debugging this more in depth.

Please don't hesitate to inform me in case the issue persists
and let me know if the above solution works for you, I look forward to your reply!

Thank you

#301299

Thanks for your efforts Beda.

Yes, you're right, the beach-house single post URL is the result of the CPT Permalinks plugin.

"If you don't have much customized content yet, this is the fastest and most secure way to have a clean install to work on."
"Please make sure to utilize updated plugins on a clean Install."
"Please let me know if you already have to much content to start over and would like to have me debugging this more in depth."

For the main issue, i would really appreciate it if you can give it another look and maybe seek the opinion of your team members to try and get to the bottom of it.

- Plugins: I haven't installed many 3rd party plugins at all. Just CPT Permalinks and WP All Import, both of which i just deactivated but still there's no difference. For the Module Manager, that is deactivated, which i just activated and it makes no difference too. This leaves the Toolset plugins, and regarding their updates ... i think you know that the Classifieds Demo requests for a lower tested version for some of them instead of the latest ones.

- Starting Over: This may be the quickest route (depending on whether you or your team's experience can identify the cause), but it would be better if we can try to learn about the root cause. This just 'suddenly' happened, and my concern is that if i start over, it could happen again and we'd be back in the same position.

Furthermore, i've tried to keep things as default as possible, without many plugins or modifications. This really shouldn't be happening and it'd be great if we can identify the problem. Or else, when the site is developed further, it would be harder to trace what's going on and easier to blame a non-Toolset element.

Hope you understand and thanks again for helping.

#301494

Thanks for the Details

I was able to reproduce this partly by disabling the "Classifieds" Theme and enabling "Toolset Bootstrap instead.

But, switching back solved the issue, and it does not seem to have the same effect on your site.

I also allowed me to upload a fresh version of "Classifieds" Theme to your install, which you now can find in Dashboard > Appearance > Themes, it has the exact same name: "Toolset Classifieds"

If you activate it, you'll see some of the issues are solved (such as the Price Short Codes not producing proper HTML)

But still the layout is not as desired, so the footer gets pushed up to the header.

I consulted this also with a Colleague and hi's opinion was as well that the Theme Files seem to be corrupted and afresh install would be in need here.

I can honestly not tell why this happened, but it seems, looking at the HTML of your current site, that the Theme's files have been changed, the entire mockup is quiet different then the default "Classifieds" mockup.

What you can do, in order to avoid to freshly install on clean Database on the live site, is this what's outlined below:

1. Reinstall the Classifieds theme on a different clean WordPress site in local or staging environment
2. Compare the files of the parent theme ‘bootstrap-theme’ directories
3. Compare the files of the child theme ‘toolset-classifieds’ directory

If you prefer I can send you both Zipped Theme Files over by DropBox, so you can install them and test it out.

I will prepare a clean WordPress example install today, so if you agree with this, I am ready to send you the files whenever you want.

You should then be able to simply rename your current Theme Files and upload the ones I send to you, to test if it works.

I am sorry I could not locate the issue (or better, the reason) for this, we are keeping an eye on this to see if it's a recurring issue, and if, take the appropriate steps.

Please let me know if you want the zipped Theme Files to test it out.

Thank you for your understanding and patience.

#302201

Thanks for your time and help Beda.

Think i'll start all over again. Will mark this as resolved but please can you update this thread if any more cases of corrupt files for the Toolset-Boostrap theme emerges.