[Resolved] Error creating relationship

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by hayleyB-3 4 months ago.

Assigned support staff: Christian Cox.

Author
Posts
#1398637

I am trying to:
Create a relationship for CPT
Link to a page where the issue can be seen:
Admin > Toolset > Relationship
I expected to see:
Relationship created
Instead, I got: Error creating relationship

#1399151

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hello, can you try these troubleshooting steps?
- Temporarily deactivate all plugins except Types and Views
- Activate a default theme like Twenty Nineteen
- Test creating a relationship again
- If the problem is resolved, reactivate your theme and other plugins and see if the new relationship continues working
- If the problem is not resolved, I'll need to take a closer look. Is it okay for me to create a clone of your site using the Duplicator plugin?

#1399275

tried all the steps provided and was not able to resolve... Still not able to create relationship

Yes go ahead and make a backup of the site using duplicator.

#1399299

This error message is sent by WordPress to our email:

Error Details
=============
An error of type E_ERROR was caused in line 143 of the file /home/wdddev50/public_html/onegiftwonder/wp-content/plugins/types/application/controllers/page/extension/edit_post_type.php. Error message: Uncaught Error: Call to a member function get_slug() on null in /home/wdddev50/public_html/onegiftwonder/wp-content/plugins/types/application/controllers/page/extension/edit_post_type.php:143
Stack trace:
#0 /home/wdddev50/public_html/onegiftwonder/wp-admin/includes/template.php(1343): Types_Page_Extension_Edit_Post_Type->metabox_relationships(NULL, Array)
#1 /home/wdddev50/public_html/onegiftwonder/wp-content/plugins/types/vendor/toolset/types/admin.php(1784): do_meta_boxes(Object(WP_Screen), 'normal', NULL)
#2 /home/wdddev50/public_html/onegiftwonder/wp-content/plugins/types/vendor/toolset/types/admin.php(667): wpcf_admin_screen('toolset_page_wp...', '

#1399791

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I can see more errors in my local clone:

WordPress database error Table 'wp_toolset_relationships' doesn't exist for query

The wp_toolset_relationships table does not exist in the database. That's not normal, there should be a relationships table in the database. Can you tell me more about how this site was created? Did you migrate a legacy post relationships site to the new relationships system, or was this content created just recently in Types 3+? Was the content migrated somehow or created here? Any details you can give me will help us track down where the problem occurred.

#1400031

I created the post type using the latest version and use the relationship under your plugin in to try and create. The site was created from scratch and was not cloned.

#1400033

will creating this table on db resolve this issue?

#1400261

Adding the table seems to solve my issue...

Another issue... I created a frontend form using Toolset's Posts Form, there is one field that is not passing the data to the DB... "Event Date".
This is the link to that form (you need to be logged in to be able to see the form): hidden link

Can you point me to where the issue lies?

#1400293

I was able to find a solution. Thanks for pointing me in the right direction 🙂

My issue is resolved now. Thank you!