Skip Navigation

[Resolved] Ensure authors can edit or delete only their own content

This thread is resolved. Here is a description of the problem and solution.

Problem: Ensure user can edit or delete only their own post using CRED form

Solution: You have set permissions for Post Types but you need to set permissions for “CRED Forms” (Access >> CRED Form) Screenshot here: https://d7j863fr5jhrr.cloudfront.net/wp-content/uploads/2017/06/536650-Cred_edit_form_access.png?x72603

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Noman 4 years, 3 months ago.

Assigned support staff: Noman.

Author
Posts
#534527
access-control-ux-files.png

I am trying to: Ensure users can edit or delete only their own content

I visited this URL: hidden link

I expected to see: No link to edit the content

Instead, I got: A link to edit the content, and then on that page a link to delete the content

I'm sure I've set the Access Control permissions up correctly, see the screen shot. So why is this not working?

#534696

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Morktron,

Thank you for contacting Toolset support. Just tested this one but I am not able to reproduce this issue at my end.

1. Please make sure all Toolset plugins are updated to latest versions as a primary check:
https://toolset.com/account/downloads/

2. Also can you please share your Debug Information with us so we can see it? I have enabled debug info box for your next reply:
https://toolset.com/faq/provide-debug-information-faster-support/

Would it be possible for you to share site login with us and then we can check what’s happening there, let me know. Thank you

#535931

Hi Noman, sorry for my slow reply. You'll need to login on the front end:

hidden link

Although I see this is not a private post, so I can't send you the login details. Please could you send the private login detail request?

Thanks

#536002

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

He Morktron,

I have also enabled private message box, your next answer will be private which means only you and I have access to it.

Thank you

#536500

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello Morktron,

Thank you for providing login details. I will use Testman account to check this issue.

I am still working on this issue and get back to you soon with an update.

Thank you for your patience.

#536650

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Cred edit form access.png

Hello Morktron,

I have checked this issue in your site and found that you have set permissions for Post Types but you need to set permissions for “Cred Forms” (Access >> CRED Form), please see attached screenshot.

I have disabled required options and now it is working as expected, please check here:
hidden link

Thank you

#536945

Aha excellent, thanks, Noman 🙂 you have resolved my issue.

Sorry I didn't realise Access has such fine-grained control over permissions. Somehow I missed those tabs at the top! It all makes sense now.

Thanks again 🙂

#537172

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I am happy that I was able to help you here and great to hear that the problem is solved now 🙂

Have a great day, Thank you