Skip Navigation

[Resolved] Enfold Theme Advanced Editor for CPTs

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 6 replies, has 3 voices.

Last updated by paulB-8 8 years, 3 months ago.

Assigned support staff: Caridad.

Author
Posts
#124193

This video: hidden link supposedly explains how to enable the Avia Advanced Editor for use with custom post types.

I have carefully followed the instructions both with and without a child theme, but it simply does not seem to work.

Theme is Enfold from ThemeForest, v1.9.1, latest WP, and latest WP-Types.

Any help would be greatly appreciated

#125829

Dear Patrick,

The theme author is using Types in the video, but he says that you can create the CPT using any other means and it should work the same. This makes me think that the problem is not related to the Types plugin.

To confirm if Types is involved in the issue, you can disable it and add these lines to functions.php in your theme:

function codex_custom_init() {
    $args = array( 'public' => true, 'label' => 'Books' );
    register_post_type( 'book', $args );
}
add_action( 'init', 'codex_custom_init' );

This will create a Books post type without using our Types plugin, then follow the instructions in the video and see if it works.

Let me know the result and we will proceed accordingly.
Regards,
Caridad

#125989

You're right Caridad. Creating a new post type without the WP-Types plugin and following the video instructions and editing meta.php:

5)	array( 'title' =>__('Avia Layout Builder','avia_framework' ), 'id'=>'avia_builder', 'page'=>array('portfolio','page','post','book'), 'context'=>'normal', 'priority'=>'high', 'expandable'=>true ),
6)	array( 'title' =>__('Layout','avia_framework' ), 'id'=>'layout', 'page'=>array('portfolio', 'page' , 'post' , 'book'), 'context'=>'side', 'priority'=>'low'),

Still no Advanced Editor. Means that the updates to Enfold Theme or another plugin must be causing the problem.

I'll post to Enfold theme support site.

Thanks!

#126713

Dear Patrick,

Thanks for getting back to us. I will close this thread now, but open a new one if you need more help.

Regards,
Caridad

#126733

Thanks, Cardid. I posted the problem to the support forum for the Enfold theme (hidden link). I gave them the same information and left a link to this discussion. There seems to be a pending update to the theme which might solve the issue. If I find out any more, I'll update this post.

#142741

i'm back, trying to fix this problem again. The updates to date have not resolved this conflict.

It's really a problem because it means manually styling any content provided by WP-Views. If you guys would work this out with Avia Editor, you could brag that this plugin is automatically compatible with Avia Advanced Layout Editor.

#340223

Here's the solution:

hidden link