Skip Navigation

[Resolved] Editing any product under the main editor I do NOT see field group I created.

This thread is resolved. Here is a description of the problem and solution.

Problem: I created Custom Fields and now want to populate them in a post. I do not see them, when I open a post to edit.

Solution: Check the conditionals added to the Custom Fields in Toolset > Post Fields > your_field_group > your_field.

It might be that you have a logic in place which makes it impossible to display the field. See this example: https://toolset.com/forums/topic/editing-any-product-under-the-main-editor-i-do-not-see-field-group-i-created/#post-586192

Bottom line, remove your conditions of any, an d re-apply them until the issue is back. Then you will know what is conflicting.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by jamesW-18 3 years, 8 months ago.

Assigned support staff: Beda.

Author
Posts
#585649
Capture2.JPG
Capture1.JPG
Capture.JPG

I am trying to: Follow the steps here: https://toolset.com/learn/create-an-ecommerce-wordpress-site/create-custom-fields-and-taxonomies/

Link to a page where the issue can be seen: Can't be seen on frontend, only backend.

I expected to see: When editing any product, expected to see field group heading with fields underneath which I can populate.

Instead, I got: Created field group. When I edit 1 specific product I see the field group and can populate the fields. When I go into any other product I only see the heading of the field group, no fields underneath.

#585880

This works just fine locally.

I think there is a hidden PHP or JS error.

1. Please enable WP Debug and visit those products. Let me know what you see.
https://codex.wordpress.org/WP_DEBUG
2. Open your Browser console and visit the products. Let me know what you see.

Probably there will be some sort of error displayed.

Please then try with Toolset only, WooCommerce and a native WordPress Theme to see if this issue still persists.

In any case I will need to know the error report, so I can try to replicate this.
For this purpose I would also need a Site's Copy if possible:
https://toolset.com/faq/provide-supporters-copy-site/

Thank you!

#586192

There are JS errors in the browser console of all pages of your WP Admin:

WebSocket connection to '<em><u>hidden link</u></em>' failed: Error during WebSocket handshake: Unexpected response code: 403

Seems related to the REST API.
Please acknowledge that Toolset does not fully support the REST API (although it also doesn't produce any error like that).

I have then deactivated all Plugins but Toolset and WooCommerce and that error was gone, but the Products fields still did not display fine.

Hence I also changed the Theme, which still did not solve the issue.

After a lot of more debug, I discovered that you have set conditions in the single Fields.

If you head to the Field's group "Product Promotions" you'll see that this group only applies to Products.
This works.

Then you see that the field "1-vendor-image" can display only if "1 - Promotion Link !=".
This means as much as field "1-vendor-image" will display only if "1 - Promotion Link" is not empty.

But that field ("1 - Promotion Link") can display only if "1 - Promotion Details !="

But then "1 - Promotion Details" displays only if "1 - Promotion Link !="

So you got no fields displayed, it's expected, since those conditions simply hide each other infinitely.

You need to remove them and adjust them, so at least one field shows always so to start adding values.

#586297

Thank you for all your time and effort on this. It is appreciated.