Skip Navigation

[Resolved] Edit button visible for admins but not for users

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 1.24 hours from now. Thank you for your understanding.

Author
Posts
#1651325

Hi I have created a My Account Page based on our tutorials and its working fine

I have also tried to create a sort of EDIT PROFILE thing but I am having an issue with the visibbility of the EDIT button.. as an administrator I can see it but as the user I can't see it.. but the role that user has been assigned, he has permission to EDIT OWN

#1651391

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for waiting, while I performed some troubleshooting.

I noticed that at WP Admin -> Toolset -> Access Control -> Toolset Forms, the users with "Optician" role were not allowed to edit their own posts using the form "My Optical Store".
( screenshot: hidden link )

I enabled that option and the edit link is now showing for the "optician" user too.

Here is a guide on access control settings for the Toolset Forms:
https://toolset.com/documentation/user-guides/access-control/access-control-for-cred-forms/

As for excluding certain pages completely from translations, I'll recommend starting a new ticket at WPML forum:
https://wpml.org/forums/forum/english-support/

regards,
Waqar

#1651429

Hi Waqar

Thanks for the update..:-).. yes it seems to work now..

A quick question.. when I click on edit, it opens in the same window.. can I make it open in a new tab?

And there's no CANCEL button in the form.. can I have a cancel button instead of being forced to SUBMIT?

And on SUBMIT, I'd like to return to the My-Account Page.. how do I do this?

Regards,
Alim

#1653569

Hi Waqar

Hope you are doing fine..:-)..

This is just a gentle reminder on the above questions..

Basically, the question is this

When editing a form, how do I open it in a new tab?
The form that opens up didn't seem to have a CANCEL option.. so the user seems to be forced to make some changes and SUBMIT... what if the user wanted to CANCEL? There seemed to be no CANCEL button.. please advise if it's some setting.
Also the redirection on SUBMIT.. If the form was not opened in a new Tab, I'd like it to come back to my accounts page. How do I do this?

Please do advise.

Regards,
Alim

#1654337

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Alim,

Thank you for waiting and I apologize for the delay in getting back on this.

I'm currently performing some tests on my website with similar form and will update you with the results, shortly.

Thank you for your patience.

regards,
Waqar

#1654981

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Alim,

Thank you for waiting.

> When editing a form, how do I open it in a new tab?

- To open the form in a new tab, you can update shortcode for the form's edit link from:


[toolset-edit-post-link content_template_slug='my-optical-store' target='self']Edit[/toolset-edit-post-link]

To:


[toolset-edit-post-link content_template_slug='my-optical-store' target='blank']Edit[/toolset-edit-post-link]

Ref: https://toolset.com/documentation/user-guides/front-end-forms/cred-shortcodes/#toolset-edit-post-link

> The form that opens up didn't seem to have a CANCEL option.. so the user seems to be forced to make some changes and SUBMIT... what if the user wanted to CANCEL? There seemed to be no CANCEL button.. please advise if it's some setting.

- The cancel button, in this case, would mean a link that returns back to the "My Account" page.

You can include an "HTML content" block at the bottom of your form fields and add a link to my account page:
( screenshot: hidden link )


<a href="[wpv-post-url item='26233']">Cancel</a>

Note: "26233" is the ID of the "My Account" page.

Ref: https://toolset.com/documentation/user-guides/views/views-shortcodes/#wpv-post-url

> Also the redirection on SUBMIT.. If the form was not opened in a new Tab, I'd like it to come back to my accounts page. How do I do this?

- For automatic redirection to the "My Account" page after the form's submission, you can change the option "After visitors submit this form" to go to a specific page and select the "My Account" page.
( screenshot: hidden link )

Alternatively, if you'd like to keep showing the custom message "The Page has been updated." after the form's submission, you can include a link to "My Account" page the same way as explained above, below your custom message, so that visitors can click it and go back.

regards,
Waqar

#1655083

Hi Waqar

Thank for the updates.. :-).. your response and explanations are super clear.. really appreciate the clarity in your explanations..:-)..

I tried all what you said and everything works fine.. but I was stuck at one point..

Note: "26233" is the ID of the "My Account" page.

I've understood this part and I know it will work fine.. but how do I find the ID of my page.. My view to list opticians and provide the EDIT link is on a PAGE that I have created but I can't seem to figure out how to get the ID of this page.. please do advise.

Regards,
Alim

#1655129

For the EDIT button, your solution about changing the target to 'blank' (is it 'blank' or '_blank') doesn't seem to work..

On editing the code the 'blank' seems to revert back to the original 'self' on update.. video screen-capture share here on a dropbox link.. please check the mov file to see what issue I am facing..

hidden link

Please advise

Regards,
Alim

#1655637

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Alim,

Thanks for the update and glad that you find my messages useful.

The simplest way to get the page/post ID is from the browser's URL bar when you're on its edit screen.
( example screenshot: hidden link )

As for the "Source code" pop-up shown in your screenshot, I'm not sure how that works or how to access it. However, directly editing the text from the "Fields and Text" block's editor worked and saved the shortcode text as expected.
( screenshot: hidden link )

I hope this helps and please let me know if you have any follow-up questions.

For each new question or concern, you're welcome to start a new ticket

regards,
Waqar

#1656481

My issue is resolved now. Thank you!

Thanks Waqar.. :-).. I was using the VIEW SOURCE to edit the EDIT link instead of moving from the VISUAL tab to the HTML tab..;-).. figured out how to do that and it was all fine..

Thanks once again.. really appreciate your patience.

Have a nice day..:-)..

Regards,
Alim