Skip Navigation

[Resolved] Don’t let user add new taxonomies

This thread is resolved. Here is a description of the problem and solution.

Problem:

The issue here is that the User wanted to remove the ability for customer's to add new taxonomies from the frontend forms.

Solution: You can actually do this through the frontend form. What you need to do is to edit your form on the backend.

Then select your taxonomy field to expand it.

Once you've click the taxonomy field you will be presented with the options.

Under "Add New" you can select "Do not let visitors add new terms".

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by romanF 1 year, 2 months ago.

Assigned support staff: Shane.

Author
Posts
#1702785
no_add_new_please.jpg
taxononies_nonewplease.jpg

I have a user content form where users should apply taxonomies. But they should only select from existing taxonomies not create new ones.
Therefore I went to toolset>access restriction>taxonomies(might be called different but you should get the idea) and changed the settings to "Assign terms". So I expected that "Anbieter" only can assign taxonomies.
I did that for all the taxonomy types I do use in this specific form but still, it looks like this: (screenshot showing form)

Thank you for your great support!

#1702909

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Screenshot 2020-07-10 at 11.05.42 AM.png

Hi Roman,

Thank you for getting in touch.

You can actually do this through the frontend form. What you need to do is to edit your form on the backend.

Then select your taxonomy field to expand it. See Screenshot for example

Once you've click the taxonomy field you will be presented with the options.

Under "Add New" you can select "Do not let visitors add new terms".

Please let me know if this helps.
Thanks,
Shane

#1703457

My issue is resolved now. Thank you!