Skip Navigation

[Closed] Custom taxonomy and custom post listing display issues

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 14 replies, has 3 voices.

Last updated by Caridad 7 years, 5 months ago.

Assigned support staff: Caridad.

Author
Posts
#66572

I have set up a custom post type and custom taxonomy for a restaurant directory. The goal is to have the taxonomies (restaurant categories) display on a page. When the user clicks on a restaurant category they will see a list of all the restaurants that are in that category. The restaurants will display in alphabetical order.

I have reviewed the support forum and docs.

I have the taxonomies displaying however when I click on one the posts display by date not alpha, although in my view I have it set to display as alpha. I can use a custom function to override this, but there has to be a way to this via the ToolSet.

Does anyone have detailed instructions on how to create a listing system with Toolset that allows for custom taxonomies to view custom posts in a custom order?

THANK YOU!!!

#66574

I should mention I have tried the classified and magazine overview to no avail. The custo order defaults to date.

#66717
#66730

Thank you. This appears to not be what I am looking for. At issue is viewing custom posts types from a custom taxonomy with a custom sort. I have already used this tutorial to no avail. Thank you though

#67106

Dear Sammut,

The order specified in the View editor should be working. Are you saying that you specify order by post title and it still shows by date?

Do you have the "post types order" plugin installed? Or some code interfering with order?

Regards,
Caridad

#67346

I have even tried this with 2012 theme. I have encountered this several times. This is why I was hoping for a some docs on doing this:

Showing custom taxonomy linking to custom posts in the taxonomy displaying by a custom order.

Thanks!

#67748

Dear Sammut,

Is this an archive page? If so, the query for those pages comes from WordPress and we cant change the order with WordPress Archives, just the layout. You can add some code to change this behaviour. Look at this post for a working solution:

https://toolset.com/forums/topic/sort-archive-view-alphabetical-or-another-order/#post-32111

Please let me know if you are satisfied with my answer and if I can help you with any other questions you might have.

Regards,
Caridad

#67834

I guess since I am using custom categories to link to custom posts in that category then it would be an archive view? My view is not set up as an archive view. It is setup as a normal view.

As such is there a way to create a directory listing with custom categories linking to custom posts that is not a archive view.

#69293

Dear Sammut,

In a new page, insert a View to list the taxonomy and below a View to list the posts. The taxonomy View would have this Meta HTML:

[wpv-layout-start]
   <ul>
      <wpv-loop>
        <li><a href="?mytax=[wpv-taxonomy-slug]">[wpv-taxonomy-title]</a></li>
      </wpv-loop>
   </ul>
[wpv-layout-end]

Then, in the posts View, add a filter to match a URL parameter, in this case 'mytax'.

Please let me know if you are satisfied with my answer and if I can help you with any other questions you might have.

Regards,
Caridad

#79320

Thank you. I added the following to create my taxonomy list:

<!-- Biz Cat Grid -->
<div id="biz-cat-grid">
[wpv-layout-start]
<!-- wpv-loop-start -->
   <wpv-loop>
    <a href="?view=[wpv-taxonomy-slug]">[wpv-taxonomy-title]</a>
   <div style="height:8px"></div>
   </wpv-loop>

<!-- wpv-loop-end -->
</div>
[wpv-no-taxonomy-found][wpml-string context="wpv-views"]<strong>No taxonomy found</strong>[/wpml-string][/wpv-no-taxonomy-found]
[wpv-layout-end]

Then I created a view and have the following set as follows:

--> Status of publish
--> Categories the same as set by the URL parameter "view" eg. hidden link"xxxx" (Taxonomy Slug)

If you look here hidden link or hidden link and click on a category you will see nothing is happening -- It shoudl be showing the listing in that taxonomy. I am not sure what else i am doing wrong.

Pardon the site's ugliness, it is just a dev site.

Thank you!

#80120

Dear Sammut

I added the filter to match the view parameter in your view and added a field to the layout. Take a look now, does it look more like what you want?

Regards,
Caridad

#80123

Ok, I see what you did. I can see results at the bottom of the category page. My hope was that when click on a category you go to new page that shows the listings without have to show all the categories on top. Thank you!

#80433

Dear Sammut,

Both Views are inserted in the same page, its a matter of placing them in different pages. I have modified your example for you to understand.

Please let me know if you are satisfied with my answer and if I can help you with any other questions you might have.

Regards,
Caridad

#80434

You are awesome! So my last question is why was/is this not working for the "Business Directory Listing View" View?

#80446

Dear Sammut,

Is almost the same as the one I created, it should work. I didn't see the shortcode for this View anywhere, this is why it didn't work.

Please let me know if you are satisfied with my answer and if I can help you with any other questions you might have.

Regards,
Caridad

The topic ‘[Closed] Custom taxonomy and custom post listing display issues’ is closed to new replies.