[Resolved] Custom search view delivering duplicate results

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I have a custom search View with a text search field. If I submit a text search, duplicate results appear. If I submit a search with one of the other filters, no duplicates are seen.

Solution: In this case Relevanssi's WPML settings should be configured to only show results from the current language.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by steinthorM 2 weeks, 2 days ago.

Assigned support staff: Christian Cox.

Author
Posts
#1387079

There is an issue with my custom search view on this page that I can't seem to figure out. I have simple search bar and a taxonomy filter in a dropdown. When I use the search bar to type in a name I get duplicate results but not when using the filter.

Link to a page where the issue can be seen: hidden link

#1387171

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Hello, can you take screenshots of this View in wp-admin so I can see the configurations? Also can you tell me how the View is added to the site - is this an Elementor View widget, or two Elementor View widgets, or a shortcode?

#1387517

It was two elementor view widgets one for search and another for results, now its just one with both.

#1388037

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thank you, I am not able to see anything obviously wrong here. Can you try these troubleshooting steps?
- Temporarily activate a default theme like Twenty Twenty, and deactivate all plugins except Types and Views.
- Place this View on a custom draft Page and preview the results.
- If the problem is resolved, reactivate your theme and test again, then begin reactivating other plugins one by one until the problem returns.
- If the problem is not resolved, I need to take a closer look.

Let me know what you find out and we can go from there.

#1388083

I had already tried these steps as it is normal in any troubleshooting request. I tried again just in case but the problem persists. What I find most strange is that it only gives double results using the text search.

#1388091

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Yes that's odd...may I log in to your wp-admin area and create a clone of the site with the Duplicator plugin? This way I can run more tests on my own local environment and monitor code execution. If that's okay, please provide admin login credentials in the private reply fields here.

#1391441

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Okay please go to wp-admin > Settings > Relevanssi > Searching and activate the WPML checkbox "Limit results to current language." Save the settings, then test again to see if the duplicate results are still present in search results. In my local tests, this fixed the problem.

#1392185

My issue is resolved now. Thank you!