Skip Navigation

[Resolved] Custom search field Taxonomy (wpv-control-post-taxonomy) wrong order

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by jean-francoisB 1 year, 9 months ago.

Assigned support staff: Minesh.

Author
Posts
#1419867
2.png
1.png

I am trying to: The taxonomy dropdown in my custom search page doesn't show the taxonomy in the order as it presented in the administration. I want the same ordering in my custom search page than the backend order.

Link to a page where the issue can be seen: hidden link

I expected to see: The order presented in the file 1.jpg attached into the dropdown presented in the file 2.jpg

Instead, I got: A random order

Thank you!

#1421227

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

[wpv-control-post-taxonomy] filter shortcode offers you order and orderby options where you can adjust your orderby field.

As you can see with our following Doc, you can set the orderby option using the following options:
'name' (default) | 'count' | 'id' | 'none' | 'slug' | 'term_group'

You can see those orderby options when you will try to add/edit your taxonomy filter. Please check the following screenshot:
=> hidden link

More info;
=> https://toolset.com/documentation/user-guides/views/views-shortcodes/#wpv-control-post-taxonomy

#1429733

Hi,

I tried your solution but whatever I put in the orderby parameter, I see no change on the dropdown order. This is the code I use :

[wpv-control-post-taxonomy taxonomy="listing-category" type="select" default_label="ALL" url_param="wpv-listing-category" taxonomy_orderby="term_group" order="ASC"]

I not sure if term_group is the good one. Which one represent the order that I want (same order in admin category list)?

Thank you,

Jeff

#1431081

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Can you please share admin access details so I'll have a closer look what's going wrong there.

*** Please make a FULL BACKUP of your database and website.***
I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

I have set the next reply to private which means only you and I have access to it.

#1432603

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thank you for sharing the access details.

I try to login to wp-admin using provided access details but it told me email was not verified and when I clicked to resend the email verification link, it must have sent an email to you.

Can you please send me working wp-admin access details.

I have set the next reply to private which means only you and I have access to it.

#1432821

Hi,

Sorry about this. I just forgot to fully activate your account. Everything should be good now.

Thank you!

#1432897

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Can you please check now: hidden link

I've modified the filter to order by name that is actually default ordering.

[wpv-control-post-taxonomy taxonomy="listing-category" type="select" default_label="ALL" url_param="wpv-listing-category"]

And with the "Custom Search Settings" section, I've set the option "Always show all values for inputs". Please check the following screenshot: hidden link

Can you please confirm it works as expected.

#1433019

My issue is resolved now. Thank you!