Skip Navigation

[Resolved] Custom role cannot set featured image (Access + WPML)

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 13 replies, has 3 voices.

Last updated by Minesh 2 years, 5 months ago.

Assigned support staff: Minesh.

Author
Posts
#1256649

I am trying to:
I have a custom role called "FR Editor". I have created a WPML Group for the French pages, and FR Editor role has all permissions selected.

I expected to see:
Users with FR Editor role should be able to set the feature image for their posts.

Instead, I got:
Users with FR Editor cannot set the featured image for their posts. They can edit and create new posts in French, but they can't set a featured image.
They used to be able to add a featured image, I think this stopped working with the latest major upgrade (2.7).

I have even tried the following (but none of this is working):
-> I have tried going to the Custom roles tab and adding the following global permissions to the role: upload_files, edit_posts, edit_published_posts, publish_posts
-> I have tried going to the Post types tab and adding the "Publish" and "Edit any" permission to the role under the Media and Posts post type.

Thanks,

#1256651
#1256847

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

Well - can you please share problem URL and access details that will help me to check your current settings and I will try to reproduce the issue based on that.

*** Please make a FULL BACKUP of your database and website.***
I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

I have set the next reply to private which means only you and I have access to it.

#1257933

Hello,

sorry, the website contains sensitive information and I'm not allowed to grant you access.

However, I've been able to reproduce this on a clean install. I can send you a copy of the database and wordpress files if you want. Or I can show you the steps to reproduce this:

1. Clean install of wordpress.
2. Install WPML + Access plugins
3. Add following languages: English (main language), Spanish and French.
4. Create a new role "FR Editor": the role should be able to publish and edit French content only, so I create the role based on the "Subscriber" role and then add permissions to it.
5. Go to "Post types" tab (within Access) and make "Posts" managed by Access. Grant permission "Edit own" and "Delete own" to "FR editor".
6. Create a WPML group (within Access settings) for "French posts" and grant all permissions to FR editor.

With this set up, "FR editor" role should be able to edit posts and set the featured image, but it's not working.

I have tried tweaking the Access settings (selecting all permissions for "Posts" (Access -> Post types tab), adding the upload_files permission to the role), but none of this is working.

Furthermore, I have also noticed that the "FR editor" role is not able to publish new posts with the new Gutenberg editor when all permissions are granted for the French language in WPML Groups tab. I need to add the generic "Publish" permission in the "Post types" tab to allow them to publish posts, but this allows them to publish posts in any language (not only French).

All of this used to work fine, I think it stopped working after the 2.7 update.

Thanks,

#1258087

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Ok - I can confirm that with "FR Editor" role when you logged in, it shows the message with Featured image field that “To edit the featured image, you need permission to upload media.” I confirm this issue and I will escalate it.

Regarding the 2nd issue, I do not able to reproduce it. I've sandbox site created here, can you please help me to reproduce the 2nd issue regarding publish button?

Login: hidden link
Username: demo
Password: Qz11sh2F3JtW

#1259185

Thanks Minesh!

Regarding the 2nd issue, I see that you have granted the "Publish" permission to "FR Editor" in Access Control -> Post Types -> Posts. That's why you are not able to reproduce this.
In my install, "FR Editor" does not have the general "Publish" permission (as this would allow them to publish posts in any language), but only the "Publish" permission in WPML Groups ->French posts. That should allow them to publish only in French.

If you install the Classic Editor, this works as expected. But with the new Blocks editor, it throws an error.

Actually, I have also noticed that with the Classic Editor it is possible to set a featured image, so both bugs are probably related to the new editor.

Thanks again,

#1259759

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Ok - with the test site I've revoked the "publish" capability for "FR Editor" in Access Control -> Post Types -> Posts. as you can see with the following link:
=> hidden link

Now, when I logged in as "FR editor" user and post is set to use the blocks editor and still I see publish button works as expected. You can login to editor user as:
U: fr-editor-user
P: Admin@123

Can you please check whats missing or why I do not able to reproduce the issue?

#1260169

Hi!

You're right, I can't reproduce the second issue either. It might be something specific to my local install.

So I think we can discard the second issue. Could you please escalate the first issue only?

Thanks again!

#1260843

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

Minesh is on holiday, you will get the answer tomorrow when he is back

#1261833

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Yes - sure. The first issue is already escalated. I'll get in touch with you as soon as I know more.

#1261863

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Our Devs has published the following errata, please try to use the workaround for now if that suits your need:
=> https://toolset.com/errata/allowing-user-roles-to-upload-media-does-not-allow-them-to-add-media-to-blocks-or-featured-images-if-gutenberg-is-active/

The issue will be fixed with next release of Toolset Access in the near future.

#1262215

I'll use the workaround for now. Thank you!

#1271439

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

#1272295

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Update:
Toolset Access versions 2.7.5 is released which contains the fix for this issue.