Skip Navigation

[Resolved] Custom role cannot edit posts

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Author
Posts
#539131
Captura de pantalla 2017-06-20 a las 16.37.40.png

I set up a "French Editor" role to allow some users to edit the French version of the site. Everything worked fine (they had permissions to edit the french posts, pages and custom post types).

Since I last updated the plugin, French editor can no longer edit or even see the Posts menu in the dashboard. However, they can still edit french pages and custom post types. I have doubled check and they have the same permissions both for french posts and french pages (using WPML Groups). However they can only edit the pages.

This worked before updating the plugin. I also have a local copy of the website on my laptop and I've also tried updating the plugin with the same results: users can no longer edit posts in one specific language (using WPML groups) while they can editor custom post types and pages.

#539190

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hello,

Thank you for contacting our support forum.

We are actually aware of this issue and a fix for it will be made in version 2.5 of our Access plugin.

What you need to do is to set Posts to be managed by Access with default permissions as a workaround.

Please let me know if this helps.
Thanks,
Shane