[Closed] Custom post relationships – There has been an error, please try again later

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Beda 2 months, 2 weeks ago.

Assigned support staff: Beda.

Author
Posts
#1451163

Hi, I setup various custom post relationships. I'm getting this error on backend when I try to create a connection: "There has been an error, please try again later."

This is the debug.log:

PHP Fatal error: Uncaught InvalidArgumentException: Invalid association ID. in /var/www
/mydomain/wp-content/plugins/cred-frontend-editor/vendor/toolset/toolset-common/inc/m2m/association/query/condition/association_id.php:23\n
Stack trace:\n#0 /var/www/mydomain/w
p-content/plugins/cred-frontend-editor/vendor/toolset/toolset-common/inc/m2m/association/query/condition_factory.php(322): Toolset_Association_Query_Condition_Association_Id->__
construct('')\n
#1 /var/www/mydomain/wp-content/plugins/cred-frontend-editor/vendor/toolset/toolset-common/inc/m2m/association/query/association_query_v2.php(884): Toolset_Assoc
iation_Query_Condition_Factory->association_id('')\n
#2 /var/www/mydomain/wp-content/plugins/types/application/controllers/ajax/handler/related_content_action.php(1196): Toolset
_Association_Query_V2->association_id('')\n
#3 /var/www/mydomain/wp-content/plugins/types/application/controllers/ajax/handler/related_content_action.php(1173): Types_Ajax_Handl
er_Related_Content_Action->get_association()\n
#4 /var/www/mydomain/wp-cont in /var/www/mydomain/wp-content/plugins/cred-frontend-editor/vendor/toolset/toolset-common/inc/m2m/a
ssociation/query/condition/association_id.php on line 23, referer: hidden link

I tested deactivating all the plugins, but I still got the error.

any suggestion?

thnaks

#1452665

Beda
Supporter

Languages: English (English ) Spanish (EspaƱol ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

I get a 404 on the link provided, so I cannot log in to see how this was built and how the error was achieved.

Can you send me a duplicate of that site, along with the steps you follow to see the error?
Usually, we can fix those fatal errors quite fast once we know how to replicate šŸ™‚

It seems to me you get that error when trying to use a Toolset Form?
Knowing how exactly it happens will allow me to narrow the error down and report it to the developers.

#1452749

Hi, to login try this:

mydomain/login/

I get the error message on wp-admin, check the screenshot. Actually I'm not getting the error when I create relationships by cred forms and by cred API custom PHP.

Now I cannot install duplicator, please set to private also the next Reply, so I will send the duplicator package.

thanks

#1452765

Beda
Supporter

Languages: English (English ) Spanish (EspaƱol ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

I saw how its setup but I can not see any such issue locally when doing the same.
I've enabled private reply areas for the duplicate.

The topic ‘[Closed] Custom post relationships – There has been an error, please try again later’ is closed to new replies.