[Resolved] Custom field changed and data lost

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by katjaL 3 months, 2 weeks ago.

Assigned support staff: Waqar.

Author
Posts
#1405285

I maybe have a bug to report.

I had a custom post type, let's say "schedule" and there a custom field "food" which was type checkboxes with 5 options. Then I created another custom post type "report" and custom field with same name "food" (accidentally, didn't get any error IMO) but this type was one checkbox without options. For clarity's sake I later changed the name (report) food to show-food.

This process changed the (schedule) food to one checkbox. I couldn't change it back to multiple checkboxes. The data is there, but to get the options back in business I had to create yet another food field with temporary name and now I have to figure out how I can move the data into the original field or somehow combine these fields.

IMHO it shouldn't have been - and usually isn't - possible to create this (report) food field at all since ths name was already taken elsewhere. Could there be a bug in these checkbox fields?

#1405627

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

I tried to reproduce this behavior on my test website with a "checkboxes" type field, but every time I tried to create a new field with the same slug as an existing one, I saw "Warning: field slug already used" message and the field was not saved.
( screenshot: hidden link )

Is it possible that the first instance of the "Food" field was created but not saved before you created and saved the new one?

Please let me know if you're still able to reproduce this on your website, along with the exact steps.

regards,
Waqar

#1405633

Hi Waqar and thank you for your reply. Yes, the first instance of the "Food" was created, saved and it had even data in it. Did you try to create the second field as "multiple checkboxes" (don't remember the real name now)? Because that was the scenario when this happened. If you can't reproduce it, I must assume it was some oddity or I have some plugin which enables this (just at this moment I can't investigate this further though).

#1405799

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for writing back.

Yes, I did test this with a number of combinations of first and second fields, including the "checkbox" and "checkboxes" type fields.

I can understand if you won't be able to investigate this further at the moment, but please do let us know if you experience this again or a pattern emerges.

#1405843

My issue is resolved now. Thank you!