Skip Navigation

[Closed] Critical Error after upgrade to latest WordPress / Toolset

This support ticket is created 2 years, 9 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

Author
Posts
#1601397

I am trying to: edit product (e.g. Price too 500Rub), than get error after click Save

Link to a page where the issue can be seen: hidden link

I'm NOT expected to see:

Fatal error: Uncaught InvalidArgumentException: incorrect post type in /var/www/u5170108/data/www/tao-online.net/wp-content/plugins/cred-frontend-editor/vendor/toolset/toolset-common/inc/autoloaded/field/group/post.php:69 Stack trace: #0 /var/www/u5170108/data/www/tao-online.net/wp-content/plugins/types/application/models/field/group/repeatable/service.php(605): Toolset_Field_Group_Post->__construct(Object(WP_Post)) #1 /var/www/u5170108/data/www/tao-online.net/wp-content/plugins/cred-frontend-editor/vendor/toolset/toolset-common/inc/autoloaded/field/group/post_factory.php(409): Types_Field_Group_Repeatable_Service->group_contains_rfg_or_prf(852) #2 [internal function]: Toolset_Field_Group_Post_Factory->{closure}(Object(OTGS\Toolset\Common\Field\Group\GroupDisplayResult)) #3 /var/www/u5170108/data/www/tao-online.net/wp-content/plugins/cred-frontend-editor/vendor/toolset/toolset-common/inc/autoloaded/field/group/post_factory.php(286): array_filter(Array, Object(Closure)) #4 /var/www/u5170108/data/www/tao-online.net/wp-conte in /var/www/u5170108/data/www/tao-online.net/wp-content/plugins/cred-frontend-editor/vendor/toolset/toolset-common/inc/autoloaded/field/group/post.php on line 69

Instead, I got: unable to save Product, can you please help to fix it asap for productive site !

please send my your email to provide a user for you

#1602315

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

To troubleshoot this issue, I'll need to see exactly how custom fields are set up for this product post type.

Can you please share temporary admin login details in reply to this message?
( feel free to use any email address for this admin user account as we just need the username and the password )

Note: Your next reply will be private and though no changes will be made on your website, please make a complete backup copy, before sharing the access details.

regards,
Waqar

#1602521

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for sharing the admin access.

I tried to check the active plugins list, but it seems that this user is not allowed to access it.

Can you please make sure that all active plugins are updated to the latest versions?

It would be interesting to test this with all non-Toolset plugins disabled and a default theme like Twenty Twenty.

If it's fixed, you can start adding the disabled items, one-by-one, to narrow down to a possible conflicting one.

Note: Please especially check for the "Broadcast" plugin ( https://wordpress.org/plugins/threewp-broadcast/ ) as we've seen similar error reports in the past when that plugin is in use.

Let me know how it goes and if it is confirmed that the issue is related to compatibility with "Broadcast" or any other plugin, a clone/snapshot of your website will be needed for further investigation.

regards,
Waqar

#1602595

OK, I'm on it

#1603767

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I'll wait to hear back from you and I've set your next reply as private, in case you need to share a clone/snapshot of the website.
( ref: https://toolset.com/faq/provide-supporters-copy-site/ )

The topic ‘[Closed] Critical Error after upgrade to latest WordPress / Toolset’ is closed to new replies.