Skip Navigation

[Resolved] Cred post forms not rendering in Safari

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Tagged: 

This topic contains 1 reply, has 2 voices.

Last updated by Beda 2 years, 3 months ago.

Assigned support staff: Beda.

Author
Posts
#1319935
Screen Shot 2019-08-20 at 1.01.12 AM.png
Screen Shot 2019-08-20 at 1.01.20 AM.png

I am trying to: Use CRED form on a page

Link to a page where the issue can be seen: hidden link

I expected to see: Form with email field and recaptcha should display. I DOES display in Chrome on Mac.

Instead, I got: I DOES display in Chrome on Mac.

It DOES NOT display at all on Safari. The entire Toolset div is completely absent from the HTML and there are no console errors.

See images below.

I made a completely fresh page, a new and separate CRED form for only adding the post title with a recaptcha and submit button.

#1320059

I work with Safari and I can see the form here hidden link if I am logged in.
Then I see the only field in the form (email) and could submit it.

Please make sure:
- you are logged in
- you are using the latest Safari version
- If you want this form to be visible for non-logged in users then alter it's rights in Toolset > Access > Toolset Forms (hidden link), and ensure the "Post Forms Frontend Access" for the desired user role are adequately allowing access where required.