Skip Navigation

[Resolved] CRED notifications not always sending post-content

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 21 replies, has 2 voices.

Last updated by Beda 4 years, 2 months ago.

Assigned support staff: Beda.

Author
Posts
#513931

I reported it and the Developers will look into this as soon as possible.

Thank you for your patience.

#514350

Is my code for the wpv-conditional from above right?

And shouldn't the test-mail below the CRED-notification send an e-mail with a random content instead of the types-fields? It doesn't. It sends an e-mail without types-content ... If this is an error too, you could report this to your Developers also.

#515185

Hi again! I got a new request from the website. I'm worried, my code for the wpv-conditional isn't right. Those fields don't appear in my notification. Please for help!

And again, please report the behaviour of the test-mail-option in CRED also to your developers.

#515188

I am sorry, I have missed this last query.

As mentioned the issue is reported.

For the other issues we require a new Ticket each:

1. shouldn't the test-mail below the CRED-notification send an e-mail with a random content instead of the types-fields?

There can be no Types fields contents as there is no Post.
It sends an email with the static content instead.

2. For the conditionals, the below are the options:

[wpv-conditional if="( $(wpcf-customer-says) eq '' )"]fdsaf[/wpv-conditional]
[wpv-conditional if="( '[wpv-post-title id="%%POST_ID%%"]' eq '' )"]fdsafs[/wpv-conditional]

In case of troubles, please open a new ticket each issue, becuase I cannot change the state of this ticket here and it won't appear in my peding queue to give you most fast attention.

Thank you for understanding.

#515203

Okay, Beda, for my second issue I opened a new ticket:
https://toolset.com/forums/topic/how-to-specify-post_id-in-cred-wpv-conditional/

And I didn't know, that it's a wanted behavior, that only empty notifications are sent by sending a test-mail. I think the test-mail would make more sense, when it would be sent with a random post of this post-type ...

#529131

This will be addressed in 1.9.1, for which I can not yet state an ETA.

I will keep you updated.

#555108

This is now all fixed in the current releases.

Please let us know if you have any other issues in a new ticket.

Thank you for the patience!