Skip Navigation

[Resolved] CRED notifications not always sending post-content

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 21 replies, has 2 voices.

Last updated by Beda 4 years, 2 months ago.

Assigned support staff: Beda.


Hi Christian,

it's me again - the annoying user with the CRED-problems from this thread
I hope you can remember me?

The problems which we discussed in this last thread are gone. CRED is working now reliable and always sends two notifications, when the CRED-form "request" was sent. But the CREDs post-content doesn't show up in all of my notifications (see my screenshots please). Luckily the content is stored in the database and shows up in the WordPress Backend, but empty notifications aren't really a good thing.

This happens on about 90 percent of all CRED-submits. There are a few, which are working, but most of the time they are empty. I can't see any reason for that in the users browser or their systems when analyzing my Google-Tracker. The problem appears even when I'm testing in exact the same browser and on my Mac – sometimes it works, sometimes they are empty ... Strange!

There are no new php-errors, except the one php-notification we discussed at the end of my last thread:

PHP Notice:  Trying to get property of non-object in /myserver/wp-content/plugins/cred-frontend-editor/library/toolset/cred/embedded/classes/common/cred_functions.php on line 72

I think the problem appeared with my last update of CRED.
Do you know of this problem?
Is it possible that this happens because my Layouts isn't updated yet?
(I can't update 'cause that breaks my existing layout.)
Or is there a new way to define the CRED-notification-fields?
(I did it like that: [types field='anfr-vorname'][/types].)

Please for your help again!


Hello Diana, Christian is off duty today.

Whenever things happen "spradically", which means not constantly reproducible, we have to first analyse dynamic issues, not static ones.

So, this means when it works sometimes but other times not, it has to do with the dynamic data.
This is for example the CONTENT that is submitted. This is never the same, right?

So, could it be that your users add HTML or other script tags to the Post Body Content?
That could cause such an issue.

There must be a explicit difference in what happens when it works, and what when not.
It can also be something with the Server.
Eventually other processes are running sometimgs, and this interrupts the current submission of a form.

Or, something with cache, and many users simoultanously submitting forms, is cuasing this.

To narrow it down, I need the exact steps to replicate it.

In the best case, it would be a list of "things to do" to achieve the problem.
Or, it can be a duplicator package with an exact instruction, of what I have to do, in order to see the problem.

I can then run that under a Debug Tool and exactly tell what goes wrong and where.
Then I can either suggest changes or report issues to the Develop Team.


I got the Site's Snapshot Files and will deploy them ASAP on a Online server, to make sure the emails notifications work, and also, so you could login there at a later moment, when I think it is working (or not)

Please expect my updates here in the forum.


We deployed the site, but you use WordFence and they locked us out since the Users and Emails are probably unknown to the Plugin's settings (I am not sure whether WordFence fetches real users or if you have to enter them manually)

I am also not sure whether you can control those settings globally, for WerdFence only?
If so you might need to add the user there, I have sent the details to you in the email.

Please let me know once we can log in.


Hi Beda, got your e-mail, but I'm not sure, what to do?

Yes, Wordfence is installed on my wordpress-live-site. But if you have a copy on your server the plugins settings are the ones from your server, aren't they? Wordfence blocks every user, which is not set in WordPress (real users).

So if you are working on a copy of mine, you can still access your site with the username and password, which I sent to you. With this user you have administrator-access. So you can disable Wordfence on your server, if you want to ...

Or does your virtual-server not allow you to log-in in WordPress with another user? If so, can't you create a new user with the credentials that I gave you for your virtual-environment?


I got back in.

You use WPML and so I wanted to test in the Original Language first.
This hidden link gives me an empty modal when I choose some search options and then "Enquiry".
I cannot submit the form, therefore.

The same happens on the English page.

Please, can you log in to the Site I sent to you in the email and check why this is not loading?
The instructions are in the Email.

This seems to be not set up correctly

Please note that for debug reasons I cannot leave all those Plugins active, I use only Toolset Software.

With a native Theme I cannot even load the modal, there seems to be a lot of Custom Code involved here.

Please acknowledge that this are things that we cannot debug, it should be replicable on a possibly minimal setup, if possible


Hi Beda,
I assume there is something wrong with your database-import. Or the search/replace in the database went wrong. Because plenty of my configuration isn't there anymore (and I don't mean the other plugins and those settings).

For example all of my custom post types (which I created with Toolset Types) are gone. That's the reason why the CRED-form can't be displayed in the modal-window. There should be the CRED-form for creating a post of my custom post type "Anfragen". But "Anfragen" is completely gone. So nothing can be shown.

I am not able to make these changes in the WordPress-Backend.
Please try to import the database again.

Yes, there is plenty of custom code on this website. But all was okay before I updated CRED. And I tested all of the CRED-related stuff with Christian before. He was able to replicate my website on one of your servers and tested it with several php- and mysql-versions. So it should also work on yours.

Or perhaps Christians testing site is still online?


I see, there must be something wrong with the Database export I got from you.

Could you do this:

1. Export all Types Data in Toolset > Export/Import and send me that zip?
2. Export all Content in Tools > Export and send me that zip?
3. Export all CRED Data in Toolset > Export/Import and send me that zip?

I can then easily re-import that content and then we can debug it.


Thank you.

I received and downloaded the Data, and I am now trying to deploy that on the Test Server.


Hi Beda, I'm one step further: With the help of your support-team I was able to update the Layouts-plugin as well.

So the good news: Now all of my Toolset-plugins are up to date. And as far as I can see the PHP-notice from cred_functions.php on line 72 is gone.

The bad news: The CRED-notification still doesn't work. In the last week, none of the notifications came in with filled in data – all of them were empty.

I'm still wondering, if there is a new way to enter the data-fields in the CRED-notifications. Because everything works fine – the data is stored in the database, the new post of custom-post-type "Anfragen" shows up correctly in Backend, the two notifications are sent. The only thing what happens is, that the data doesn't show up in the notifications.

So is there anything to verify the data in a more specific way?
Perhaps I can define the ID of the post in any way, just like:

[types field='anfr-vorname' id='THISID'][/types]

Yes, you can use as example:

[types field='anfr-vorname' id='%%POST_ID%%'][/types]

Or, you might try to use:

[types field='anfr-vorname' id='[wpv-post-id]'][/types]

Although the last one will not work properly I suspect.

Please let me know if that solves the issue.


Hi Beda!
I tried to add the %%POST_ID%%. My tests are good now. But I'm waiting for a new CRED-request from a customer. After that I can say whether it really works or not. I'll be back ...

But for my understanding: Is this required for all of my other projects, too, when I'm updating the Toolsets components to the latest versions?


It's not needed, but a workaround when it does not work without the ID attribute.

Supposedly this is supposed to work just fine:

[types field='anfr-vorname' ][/types]

If that fails, you can use

[types field='anfr-vorname' id='%%POST_ID%%'][/types]

But it's not required.

If you see this issue also on other sites, please don't hesitate to inform me.
This has been reported in past as a BUG but was solved.

It might be back, I need to ask our In DEV testers for some accurate double-checking.


In my case, it's definitely required after the update: It works now with the given id. But I didn't update my other sites. Hopefully, this will be solved in the next update. Then I'll give it a try again.

One problem: I have conditional inputs in my notification-e-mails, and they do not work without the id either. How can I put the id in there? So for example in here:

[wpv-conditional if="( $(wpcf-anfr-telefon) ne '']Telefon[/wpv-conditional]

I had to update another site of mine, and there I had the same issue. I had to fill in the ID in the CRED-notifications as well. And for my wpv-conditional I now tried it this way – hope it helps:

[wpv-conditional if="( $(wpcf-anfr-telefon).id(%%POST_ID%%) ne '']Telefon[/wpv-conditional]

So for me it's pretty sure, that this is an Update-Bug in CRED, isn't it?
Since you said, that this bug didn't appear for the first time, it's a little bit frustrating, that I couldn't get the hint for setting the ID a little bit earlier. My client wasn't really happy, that this didn't work for such a long time ... But anyway, would you please report this to your developers? Thanks!